Opened 6 years ago

Closed 6 years ago

#9622 closed bug (fixed)

no sound on Thinkpad x120e in hrev45438 gcc2h

Reported by: tidux Owned by: korli
Priority: normal Milestone: Unscheduled
Component: Drivers/Audio/HDA Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This laptop has probably one of the screwier edge cases for the HDA driver - it has a primary sound card with speaker and headphone output, and a second sound card that allows HDMI audio output. Both of these use the HDA driver on Linux. Only one soundcard shows up under Haiku. The only output listed is "left headphones," but no sound actually comes out of the headphone port on the left side of the system. Attached are the syslog, sysinfo, and listdev for the machine in question.

Attachments (3)

listdev.x120e (3.6 KB) - added by tidux 6 years ago.
sysinfo.x120e (2.2 KB) - added by tidux 6 years ago.
syslog.x120e (332.0 KB) - added by tidux 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by tidux

Attachment: listdev.x120e added

Changed 6 years ago by tidux

Attachment: sysinfo.x120e added

Changed 6 years ago by tidux

Attachment: syslog.x120e added

comment:1 Changed 6 years ago by pulkomandy

Milestone: R1/beta1Unscheduled

Moving hardware-sepcific issues out of beta1.

comment:2 Changed 6 years ago by tidux

Please close this ticket, as sound works flawlessly out of the box on that same x120e in hrev46791 gcc2h x86.

comment:3 Changed 6 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Thanks for reporting!

Note: See TracTickets for help on using tickets.