Opened 6 years ago

Closed 6 years ago

#9641 closed bug (duplicate)

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x8, ip 0x80056a97

Reported by: Robert S. Owned by: mmlr
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: port heap Cc:
Blocked By: #8028 Blocking:
Has a Patch: no Platform: All

Description (last modified by anevilyak)

Hi,

I got an KDL with the following strack trace (I hope it is not dupplicated, but I couldn't find a similar ticket). I got this KDL in hrev45257 gcc2h.

stack trace for thread 69 "timer_thread"
kernel stack: 0x8176a000 to 0x8176e000
user stack: 0x70049000 to 0x70089000
frame caller <image>:function + offset
0 8176d974 (+ 48) 80095238 <kernel_x86> invoke_command_trampoline([34m0x8176da0c[0m) + 0x1c
1 8176d9a4 (+ 12) 80123f32 <kernel_x86> arch_debug_call_with_fault_handler + 0x1b
2 8176d9b0 (+ 48) 800941b2 <kernel_x86> debug_call_with_fault_handler + 0x5e
3 8176d9e0 (+ 64) 80095491 <kernel_x86> invoke_debugger_command + 0xb9
4 8176da20 (+ 64) 800952bd <kernel_x86> invoke_pipe_segment(debugger_command_pipe*: [34m0xcce38030[0m, int32: [34m0[0m, [34m0x0[0m [31m"<NULL>"[0m) + 0x79
5 8176da60 (+ 64) 800955fc <kernel_x86> invoke_debugger_command_pipe + 0x9c
6 8176daa0 (+ 48) 80097298 <kernel_x86> ExpressionParser<[32m0x8176db50[0m>::_ParseCommandPipe([34m0x8176db4c[0m) + 0x234
7 8176dad0 (+ 64) 800964b8 <kernel_x86> ExpressionParser<[32m0x8176db50[0m>::EvaluateCommand([34m0x8019ff60[0m [36m"sc | qrappend"[0m, [34m0x8176db4c[0m) + 0x2d0
8 8176db10 (+ 224) 800988e4 <kernel_x86> evaluate_debug_command + 0x80
9 8176dbf0 (+ 64) 80092a3e <kernel_x86> kernel_debugger_loop([34m0x801700f7[0m [36m"PANIC: "[0m, [34m0x80185f80[0m [36m"vm_page_fault: unhandled page fault in kernel space at 0x%lx, ip 0x%lx
"[0m, [34m0x8176dc9c[0m [36m""[0m, int32: [34m0[0m) + 0x32a
10 8176dc30 (+ 48) 80092c93 <kernel_x86> kernel_debugger_internal([34m0x801700f7[0m [36m"PANIC: "[0m, [34m0x80185f80[0m [36m"vm_page_fault: unhandled pagefault in kernel space at 0x%lx, ip 0x%lx
"[0m, [34m0x8176dc9c[0m [36m""[0m, int32: [34m0[0m) + 0x53
11 8176dc60 (+ 48) 8009453e <kernel_x86> panic + 0x36
12 8176dc90 (+ 144) 80108cd5 <kernel_x86> vm_page_fault + 0x13d
13 8176dd20 (+ 80) 80132ace <kernel_x86> x86_page_fault_exception + 0x17e
14 8176dd70 (+ 12) 801269e0 <kernel_x86> int_bottom + 0x30
kernel iframe at 0x8176dd7c (end = 0x8176ddcc)
eax 0x8295f400 ebx 0x0 ecx 0x8116e000 edx 0x8019f3ec
esi 0x0 edi 0x8295f568 ebp 0x8176ddf4 esp 0x8176ddb0
eip 0x80056a97 eflags 0x13286 
vector: 0xe, error code: 0x0
15 8176dd7c (+ 120) 80056a97 <kernel_x86> heap_allocate_from_bin(heap_allocator_s*: [34m0x8295f400[0m, uint32: [34m0xa[0m ([34m10[0m), uint32: [34m0x60[0m ([34m96[0m)) + 0xd3
16 8176ddf4 (+ 48) 80056d97 <kernel_x86> heap_memalign + 0xa3
17 8176de24 (+ 80) 80061ca5 <kernel_x86> get_port_message(int32: [34m1886023792[0m, uint32: [34m0x44[0m ([34m68[0m), uint32: [34m0x9[0m ([34m9[0m), int64: [34m0[0m, port_message*: [34m0x8176ded4[0m, Port&: [34m0xce3c8e78[0m) + 0x271
18 8176de74 (+ 128) 80063dbe <kernel_x86> writev_port_etc + 0x2d6
19 8176def4 (+ 80) 80064658 <kernel_x86> _user_write_port_etc + 0xe0
20 8176df44 (+ 100) 80126bd0 <kernel_x86> handle_syscall + 0xcd
user iframe at 0x8176dfa8 (end = 0x8176e000)
eax 0xd8 ebx 0x6938e8 ecx 0x70088c70 edx 0xffff0114
esi 0x0 edi 0x706a7070 ebp 0x70088cac esp 0x8176dfdc
eip 0xffff0114 eflags 0x3217 user esp 0x70088c70
vector: 0x63, error code: 0x0
21 8176dfa8 (+ 0) ffff0114 <commpage> commpage_syscall + 0x04
22 70088cac (+ 64) 003775ed <libbe.so> BMessage<[32m0x182f2da0[0m>::_SendFlattenedMessage([34m0x44[0m, int32: [34m452[0m, int32: [34m53[0m, int32: [34m0[0m, int64: [34m1730461599371624448[0m) + 0x89
23 70088cec (+ 64) 0023c503 <_APP_> MessageDeliverer<[32m0x1801d150[0m>::_SendMessage(MessageDeliverer::Message*: [34m0x182aede0[0m, int32: [34m452[0m, int32: [34m53[0m) + 0x33
24 70088d2c (+ 128) 0023be3b <_APP_> MessageDeliverer<[32m0x1801d150[0m>::DeliverMessage([34m0x18388c70[0m, int32: [34m68[0m, MessagingTargetSet&: [34m0x70088e7c[0m, int64: [34m9223372036854775807[0m) + 0x26b
25 70088dac (+ 112) 0023bb65 <_APP_> MessageDeliverer<[32m0x1801d150[0m>::DeliverMessage(BMessage*: [34m0x1801b090[0m, MessagingTargetSet&: [34m0x70088e7c[0m, int64: [34m9223372036854775807[0m) + 0x91
26 70088e1c (+ 112) 0023ba2e <_APP_> MessageDeliverer<[32m0x1801d150[0m>::DeliverMessage(BMessage*: [34m0x1801b090[0m, BMessenger: [34m0x70088ee8[0m, int64: [34m9223372036854775807[0m) + 0x4e
27 70088e8c (+ 128) 0024042b <_APP_> MessageRunnerManager<[32m0x182949e0[0m>::_DoEvent(MessageRunnerManager::RunnerInfo*: [34m0x18047810[0m) + 0x11f
28 70088f0c (+ 48) 00240756 <_APP_> MessageRunnerManager::RunnerEvent<[32m0x182904e0[0m>::Do(EventQueue*: [34m0x18048440[0m) + 0x26
29 70088f3c (+ 64) 0023b278 <_APP_> EventQueue<[32m0x18048440[0m>::_EventLooper([34m0x0[0m) + 0x114
30 70088f7c (+ 48) 0023b15b <_APP_> EventQueue<[32m0x18048440[0m>::_EventLooperEntry(NULL) + 0x1f
31 70088fac (+ 48) 005ee893 <libroot.so> _get_next_team_info (nearest) + 0x5f
32 70088fdc (+ 0) 70088fec 1939:timer_thread_69_stack@0x70045000 + 0x43fec

message:

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x8, ip 0x80056a97

Change History (2)

comment:1 by anevilyak, 6 years ago

Component: System/libroot.soSystem/Kernel
Description: modified (diff)
Keywords: port heap added
Owner: changed from axeld to mmlr
Status: newassigned

comment:2 by anevilyak, 6 years ago

Blocked By: 8028 added
Resolution: duplicate
Status: assignedclosed

Thought I'd seen it before...duplicate of #8028.

Note: See TracTickets for help on using tickets.