Opened 6 years ago

Closed 6 years ago

#9649 closed bug (fixed)

Problem with formating: Time 24h and freeze

Reported by: Hubert Owned by: anevilyak
Priority: normal Milestone: R1
Component: Kits/Locale Kit Version: R1/Development
Keywords: locale, 24h, formating, freeze Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I found interesting and unpalatable error in hrev hrev45464 gcc4h. I choose Locale with Preferences and change time formating with 12 on 24 and I have total freeze system. After hard reboot system restart but I see only my workspace nad disc icon with /boot, any Deskbar Menu(http://www.haiku-os.org/docs/userguide/en/deskbar.html#deskbar-menu) and Restart Desktop not help. I did reproduce that bug on new instalation this hrev.

Attachments (1)

syslog (175.1 KB) - added by Hubert 6 years ago.
log

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by anevilyak

Component: Preferences/LocaleKits/Locale Kit
Priority: criticalnormal

Is a syslog available from when this happens?

comment:2 Changed 6 years ago by Hubert

Hej anevilyak. No, I can save syslog because system is totaly dead after change. And this is cause why I set critical (or high) for this bug. System system is not able to continue to work even after a reboot. I tried use checkfs with other instalation but it did not help. After crash and reboot system can't boot Deskbar properly.

comment:3 Changed 6 years ago by anevilyak

Not reproducible over here at least so there has to be something additional that's influencing this issue. Need to determine what though.

comment:4 Changed 6 years ago by Hubert

I boot that version now and restart and with other system I took syslog.

anevilyak: You tested on hrev45464 gcc4h? Earlier works correctly.

Changed 6 years ago by Hubert

Attachment: syslog added

log

comment:5 Changed 6 years ago by jscipione

I can reproduce this one on hrev45473 gcc4, change the radio button and total system freeze, reboot and Deskbar doesn't load.

Last edited 6 years ago by jscipione (previous) (diff)

comment:6 Changed 6 years ago by Hubert

I tested on hrev45444 gcc4h and problem does not exist.

comment:7 Changed 6 years ago by anevilyak

Owner: changed from pulkomandy to anevilyak
Status: newin-progress

comment:8 Changed 6 years ago by anevilyak

Fixed in hrev45476.

comment:9 Changed 6 years ago by anevilyak

Resolution: fixed
Status: in-progressclosed
Note: See TracTickets for help on using tickets.