Opened 6 years ago

Closed 6 years ago

#9667 closed bug (fixed)

Deskbar does not keep changes after second boot.

Reported by: Premislaus Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc:
Blocked By: #9632 Blocking:
Has a Patch: no Platform: All

Description

Deskbar does not keep changes after second boot. This applies to Deksbar and Time preferences. I have to make changes again! I have this bug for a long time, just forgot to report.

This is hrev45487 gcc2h.

Attachments (4)

Deskbar_settings_first_boot_after_install.png (126.8 KB ) - added by Premislaus 6 years ago.
Deskbar_settings_second_boot.png (545.0 KB ) - added by Premislaus 6 years ago.
Deskbar_settings_third_boot.png (515.0 KB ) - added by Premislaus 6 years ago.
syslog (493.0 KB ) - added by Premislaus 6 years ago.

Download all attachments as: .zip

Change History (6)

by Premislaus, 6 years ago

by Premislaus, 6 years ago

by Premislaus, 6 years ago

Attachment: syslog added

comment:1 by jscipione, 6 years ago

Blocked By: 9632 added

It seems that this bug is related to #9632. Deskbar settings not getting saved seems to happen always with a slow shutdown. The first image is fine, Deskbar initially creates a 0 size file on startup and then fills it out on quit. The second image shows the problem, the setting file didn't get filled out because of something related to #9632. The third image shows the setting file getting filled out correctly.

comment:2 by jscipione, 6 years ago

Resolution: fixed
Status: newclosed

This bug should also be fixed in hrev45512, it was caused by Deskbar not shutting down correctly and thus not saving it's settings.

Note: See TracTickets for help on using tickets.