Opened 6 years ago

Last modified 2 years ago

#9681 assigned bug

Failure to boot off Hard Drive

Reported by: scanty Owned by: nobody
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/alpha4.1
Keywords: Cc: bug5lay4r@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Yesterday morning I tried to install Haiku to its own hard drive and had absolutely no success in booting. I used an alpha 4.1 ISO to do this. GRUB found Haiku automagically, but couldn't boot it. I just get a black screen with a flashing cursor in the upper left corner. If I advance to the next partition in GRUB (/dev/sdb1 instead of /dev/sdb, where it should be) I get the Haiku boot menu, but fail to scan for any bootable volumes. Not sure what's going on here.

Change History (6)

comment:1 by scanty, 6 years ago

My mistake. Haiku lives on /dev/sdb1. Sorry.

comment:2 by scanty, 6 years ago

If it helps at all, I tried booting via QEMU and it says:

Booting from Hard Disk...bad superblock.

I can't help but wonder if the problems are related.

comment:3 by scanty, 6 years ago

Tried the Haiku boot menu. Only the CD, and not the hard drive is listed there. Seems like maybe this drive is not being detected.

comment:4 by scanty, 6 years ago

Possibly a hardware/implmentation bug. I just tried a different hard drive and still get a black screen with white flashing cursor.

comment:5 by zzzzz, 6 years ago

Cc: bug5lay4r@… added
Component: - GeneralSystem/Boot Loader
Owner: changed from nobody to axeld

Can't say about QEMU, but currently Haiku can be booted only from 1st disk. See ticket #3545 for reference. So I suggest to close it as a duplicate.

comment:6 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned
Note: See TracTickets for help on using tickets.