Opened 6 years ago

Closed 6 years ago

#9693 closed bug (invalid)

WebPositive crashes on hrev45533 with KDEBUG_LEVEL = 0

Reported by: rossi Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by anevilyak)

See attached report.

Attachments (1)

Webpositive_crash.report (15.8 KB ) - added by anevilyak 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 by rossi, 6 years ago

Additional checks: also happens on the same hrev with KDEBUG_LEVEL 2 and on hrev45517

comment:2 by anevilyak, 6 years ago

Does it make a difference if you remove ~/config/settings/Webpositive? Not seeing it here.

comment:3 by rossi, 6 years ago

Doesn't make any difference for me. Also tried with all cores except one disabled and a vbox config, with just one CPU. All makes no difference. (Systems is gcc2hybrid)

by anevilyak, 6 years ago

Attachment: Webpositive_crash.report added

in reply to:  3 comment:4 by anevilyak, 6 years ago

Description: modified (diff)

comment:5 by anevilyak, 6 years ago

Since I assume you're building yourself, given that you're setting/changing KDEBUG_LEVEL, can I ask if you've tried doing a jam clean (for both the gcc2 and 4 generated subdirs)? This crash really doesn't make any sense for the code path in question unless there's a stale/out of date object somewhere.

comment:6 by rossi, 6 years ago

Yes, your assumption is correct. I did do a jam clean from the gcc2 dir, assuming that is sufficient, since I never invoked jam from the gcc4 dir. Do I need tu run a separate jam clean from inside the gcc4 dir? I assumed jam clean invoked from the same dir would clean everything including the alternate gcc4 libs built.

I'll try again tomorrow with a jam clean from all dirs, hoping that solves the issue. Thx for the hint!

in reply to:  6 comment:7 by anevilyak, 6 years ago

Replying to rossi:

Yes, your assumption is correct. I did do a jam clean from the gcc2 dir, assuming that is sufficient, since I never invoked jam from the gcc4 dir. Do I need tu run a separate jam clean from inside the gcc4 dir? I assumed jam clean invoked from the same dir would clean everything including the alternate gcc4 libs built.

You didn't explicitly invoke it, no, but when performing a hybrid build, a subjam in the alternative gcc's generated subdir is implicitly invoked in order to build said libs. Note also that this includes Webpositive itself since it must be linked against webkit, which is gcc4 only. Jam clean unfortunately only cleans the current compiler's generated dir, and does not implicitly clean the alternate, so this must in fact be done manually.

comment:8 by rossi, 6 years ago

not a bug, build issue was indeed the cause. sorry for the inconvenience. please close as invalid.

comment:9 by anevilyak, 6 years ago

Resolution: invalid
Status: newclosed

Thanks for the update!

Note: See TracTickets for help on using tickets.