Opened 6 years ago

Closed 6 years ago

#9753 closed bug (fixed)

Menu Field with frame (non-layout) and not fixed size should truncate label if item is wider than frame

Reported by: IMadering Owned by: jscipione
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description


Attachments (3)

screenshot1.png (28.5 KB) - added by IMadering 6 years ago.
Info window at 18pt font in Russian locale.png (21.2 KB) - added by jscipione 6 years ago.
Fixed this bug, but, there are still other layout problems in this window
Menu Field truncation BeOS.png (12.3 KB) - added by jscipione 6 years ago.
Screenshot showing what happens in BeOS, it does in fact truncate the field

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by IMadering

Attachment: screenshot1.png added

comment:1 Changed 6 years ago by stippi

Owner: changed from stippi to jscipione
Status: newassigned

John, might this be a regression of your recent changes?

Changed 6 years ago by jscipione

Fixed this bug, but, there are still other layout problems in this window

comment:2 Changed 6 years ago by jscipione

Resolution: fixed
Status: assignedclosed

AFAIK this was not caused by my recent changes, but I fixed it anyway in hrev45644

Changed 6 years ago by jscipione

Screenshot showing what happens in BeOS, it does in fact truncate the field

comment:3 Changed 6 years ago by jscipione

Component: User InterfaceKits/Interface Kit
Resolution: fixed
Status: closedreopened
Summary: No normal size ComboBox in Information windowMenu Field with frame (non-layout) and not fixed size should truncate label if item is wider than frame

comment:4 Changed 6 years ago by jscipione

I re-opened this bug report because I am not satisfied with the bug fix I did, it really just hides the bug. I checked the behavior on BeOS 5 and the menu field does in fact get truncated when the label of the selected menu item is wider than the available space allotted for the menu portion of the menu field.

comment:5 Changed 6 years ago by jscipione

Resolution: fixed
Status: reopenedclosed

Fixed (for real this time) in hrev45651. The menu field is once again in auto-resize mode, but if the width of the selected menu item is wider than the available space allotted for the menu than the menu field truncates the menu item to fit. This reproduces the behavior on BeOS more-or-less.

Note: See TracTickets for help on using tickets.