Opened 6 years ago

Closed 6 years ago

#9809 closed bug (fixed)

Terminal uses incorrect line count after adding new tab

Reported by: ThFabba Owned by: jackburton
Priority: low Milestone: R1
Component: Applications/Terminal Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After adding a second tab, the terminal line count reported to applications seems to be wrong in the first tab.

(Resolution: 1024x768)

To reproduce:

  • Start Terminal and maximize it
  • Terminal -> New Tab (Alt+T)
  • Alt+1 to switch back to the first tab
  • nano /var/log/syslog
  • Note that nano is only showing one menu line (attached screenshot)
  • Press Page Down, some text from the previous page will appear instead of the text that should be there ("USER: failed to create the required index ..." in screenshot)
  • Page Up, Page Down, second page text now displays right

Same happens again after closing and reopening nano. Does not happen in second tab (Alt+2). Resizing the Terminal window fixes the issue.

Attachments (1)

Haiku-terminal-bug-nano.png (116.1 KB ) - added by ThFabba 6 years ago.
Screenshot

Download all attachments as: .zip

Change History (4)

by ThFabba, 6 years ago

Attachment: Haiku-terminal-bug-nano.png added

Screenshot

comment:1 by diver, 6 years ago

Does it still happen in nigltly builds?

comment:2 by siarzhuk, 6 years ago

Just to clear:

  • Start Terminal;
    ~> tput lines
    ~> 37
    
  • <Alt-T>
    ~> tput lines  # second tab
    ~> 36
    

That is OK - the tabline was added above and height of terminal view was decreased.

  • <Alt-1>
    ~> tput lines  # first tab
    ~> 37
    

That is wrong - the height must be adjusted because change of viewport's height too.

Looks like corresponding window size change signal is not send to the first tab's application after adding/removing tabs.

comment:3 by siarzhuk, 6 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev46011. Thank you for report.

Note: See TracTickets for help on using tickets.