Opened 6 years ago

Closed 6 years ago

#9826 closed bug (fixed)

wpa_supplicant crashes in package management version

Reported by: X512 Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/Package Management
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by anevilyak)

wpa_supplicant is always crashes when trying connect to any WPA2 encrypted network.

Attachments (1)

wpa_supplicant-193-debug-19-06-2013-08-21-38.report (10.1 KB) - added by X512 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by anevilyak

Description: modified (diff)

A syslog and/or crash report would be helpful.

comment:2 Changed 6 years ago by anevilyak

That looks to be the older version of wpa_supplicant, that package was just updated last night.

Would be interesting to know if removing the current package and replacing it with http://haiku-files.org/files/hpkg/wpa_supplicant-2.0-3-x86_gcc2.hpkg makes a difference.

comment:3 in reply to:  2 Changed 6 years ago by X512

Replying to anevilyak:

That looks to be the older version of wpa_supplicant, that package was just updated last night.

Would be interesting to know if removing the current package and replacing it with http://haiku-files.org/files/hpkg/wpa_supplicant-2.0-3-x86_gcc2.hpkg makes a difference.

This works. Now I can connect to WPA2 network. Unfortuneately WebPositive can't be used without GCC4 libraries, but NetPositive is running.

comment:4 Changed 6 years ago by anevilyak

Resolution: fixed
Status: newclosed

Thanks for the update! The hybrid issue will be taken care of eventually.

Note: See TracTickets for help on using tickets.