Opened 6 years ago

Closed 4 years ago

#9844 closed bug (fixed)

Build failure on OS X due to GCC assuming case-insensitive FS

Reported by: xyzzy Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After updating buildtools to GCC 4.7.3 on OS X, it is no longer possible to build Haiku as GCC is behaving as though the filesystem is case-insensitive even though it is not. I've found the cause of this and reported it upstream (http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57768), just opening a ticket here so that we can track the progress of a fix and backport it to our GCC version.

Change History (4)

comment:1 Changed 6 years ago by korli

I'm afraid we won't get much support given the non-mainstream aspect of the bug.

Have you tried to define HAVE_CASE_INSENSITIVE_FILE_SYSTEM to 0?

For reference here is the revision cited in the GCC bug.

comment:2 Changed 6 years ago by xyzzy

Worked around in btrev43059 by undefining HAVE_CASE_INSENSITIVE_FILE_SYSTEM.

comment:3 Changed 4 years ago by pulkomandy

Can we close this ticket? It seems the workaround is enough, or maybe later versions of GCC fixed this already?

comment:4 Changed 4 years ago by xyzzy

Resolution: fixed
Status: newclosed

Yes, the OS X build is currently working so this can be closed.

Note: See TracTickets for help on using tickets.