Opened 6 years ago

Closed 6 years ago

#9848 closed bug (invalid)

[package] only extracts .PackageInfo

Reported by: diver Owned by: bonefish
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/Package Management
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

package extract package.hpkg only extracts .PackageInfo file, whereas I expect it to extract the whole package.

Change History (3)

comment:1 Changed 6 years ago by diver

Alright, mkdir foo followed by package extract -C foo package.hpkg did the trick. Although, it looks like -C switch is optional.

comment:2 Changed 6 years ago by bonefish

The "-C" option really doesn't do anything more than "cd" into the target directory after opening the package file and before starting to extract it. With the packages I've tested it so far, extraction worked just fine without the option. Which package did you try?

comment:3 Changed 6 years ago by diver

Resolution: invalid
Status: newclosed

Hmm, it works now too with makefile_engine.hpkg. Mea culpa then.

Note: See TracTickets for help on using tickets.