Opened 6 years ago

Closed 6 years ago

#9862 closed bug (fixed)

[KeymapSwitcher] Available keymaps list is reversed

Reported by: diver Owned by: bonefish
Priority: normal Milestone: R1
Component: Applications Version: R1/Package Management
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Available keymaps list in KeymapSwitcher prefs window is reversed in Haiku.PM while it's ok in hrev45850.

Change History (3)

comment:1 by bonefish, 6 years ago

Other sorting issues I've noticed:

  • The list sorting in the Keymap preflet doesn't seem to work at all.
  • In Pe the list of the programming language popup in the info window is also reversed.

I don't know, if that is actually the case, but a possible explanation could be that in all those cases the application doesn't sort the list at all, but rather just fills it as it reads the entries from a certain directory (keymap files, add-ons). I believe BFS's on-disk structures require/imply directory entries to be sorted while that is not the case for packagefs.

If this assumption is correct then the issue is actual a bug/missing feature in the concerned applications. One that also exists in the non-PM Haiku, though it may be less visible. I guess it can still be observed when setting a locale whose sorting doesn't agree with BFS's.

comment:2 by anevilyak, 6 years ago

Component: - GeneralApplications

At least for the keymap preflet, this is correct, it puts them in the list in the order that they're returned by BDirectory::GetNextRef(). Not sure about Pe right now but I'd guess its case is the same, since your assumption about BFS's on-disk structures is indeed the case (as for any other filesystem that's based on some derivative of a B-tree).

comment:3 by diver, 6 years ago

Resolution: fixed
Status: newclosed

Keymap sorting is fixed in hrev46353 KeymapSwitcher is fixed in 1a52683/hrev46834

Closing as fixed.

Note: See TracTickets for help on using tickets.