Opened 13 years ago

Closed 12 years ago

#989 closed bug (fixed)

Expander crashes when unzipping

Reported by: jackburton Owned by: korli
Priority: normal Milestone: R1
Component: Applications/Expander Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  • Open a zip file with expander.
  • Try to unzip it
  • Expander will crash.

Attachments (1)

IMG004.JPG (161.2 KB ) - added by jackburton 13 years ago.
backtrace

Download all attachments as: .zip

Change History (8)

by jackburton, 13 years ago

Attachment: IMG004.JPG added

backtrace

comment:1 by korli, 13 years ago

Could it be a regression ? On which revision does this happen ?

Could you retry without the revision 19951 (just an idea) ? Thanks

in reply to:  1 comment:2 by jackburton, 13 years ago

Replying to korli:

Could it be a regression ? On which revision does this happen ?

Could you retry without the revision 19951 (just an idea) ? Thanks

It's been happening since some time actually, also before hrev19951.

comment:3 by korli, 13 years ago

I can't reproduce this with the zip file Konatu_ver_18.zip (9MB) on Qemu on a 120MB Haiku image with the revision 19958. Could you elaborate on your testcase ?

comment:4 by jackburton, 13 years ago

Resolution: fixed
Status: newclosed

I can't seem to reproduce this problem either. I'll reopen if needed.

comment:5 by jackburton, 13 years ago

Resolution: fixed
Status: closedreopened

Seems to happen randomly. I'll try to find a way to reproduce it consistently.

comment:6 by korli, 12 years ago

Does this still happen ? I know Axel and Ingo fixed some VM bugs.

comment:7 by korli, 12 years ago

Resolution: fixed
Status: reopenedclosed

Closing ...

Note: See TracTickets for help on using tickets.