Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#9894 closed enhancement (duplicate)

Add support for A6-4400M APU - Radeon HD 7520g and 7670m

Reported by: Premislaus Owned by: kallisti5
Priority: normal Milestone: R1
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have two graphics cards in my laptop - Radeon HD 7520g and 7670m. My laptop is a Samsung NP355V5C-S05PL with A6-4400M APU. Unfortunately Haiku uses the VESA driver.

Attachments (4)

syslog (140.4 KB ) - added by Premislaus 6 years ago.
listdev (3.5 KB ) - added by Premislaus 6 years ago.
syslog.2 (495.6 KB ) - added by Premislaus 6 years ago.
syslog.3 (173.0 KB ) - added by Premislaus 6 years ago.
hrev47196

Download all attachments as: .zip

Change History (11)

by Premislaus, 6 years ago

Attachment: syslog added

by Premislaus, 6 years ago

Attachment: listdev added

comment:1 by kallisti5, 6 years ago

added in hrev45933 Not sure what the result will be though as this configuration is pretty far out there. If the laptop uses Display Port bridges, it will not function (and you'll likely see a white screen full of pretty lines, #8626). We can't tell on that until we add the PCIID.. so provide a syslog after you get a chance to test the change. :)

comment:2 by ttcoder, 6 years ago

Cc: degea@… added

comment:3 by Premislaus, 6 years ago

{0x9990, 6, 1, RADEON_ARUBA, CHIP_APU, "Radeon HD 7920"}, - It should be 7520g ;-).

Currently I can not test - #9941

comment:4 by Premislaus, 6 years ago

hrev47167

After boot I have white screen for one second. After that I have black screen. I must to use VESA mode.

by Premislaus, 6 years ago

Attachment: syslog.2 added

by Premislaus, 6 years ago

Attachment: syslog.3 added

comment:5 by kallisti5, 6 years ago

Resolution: duplicate
Status: newclosed

Thanks for the information, this is a duplicate of #8626

We don't support Radeon HD 6xxx+ laptops well yet as they only use DisplayPort bridges internally. Our DP code is still a little rough and the bridges are extremely hard to configure.

Likely if we have another alpha / beta I'll comment out all of the later mobile GPU's so they fall back to VESA. For now, you may want to blacklist radeon_hd.

comment:6 by kallisti5, 6 years ago

(The key of matching this issue to #8626 was the Nutmeg encoder. Nutmeg / Travis are red flags)

comment:7 by ttcoder, 5 years ago

Cc: degea@… removed
Note: See TracTickets for help on using tickets.