Opened 12 years ago

Closed 12 years ago

#993 closed bug (fixed)

page fault with interrupts disabled under vmware

Reported by: jackburton Owned by: marcusoverhagen
Priority: critical Milestone: R1
Component: Drivers/Network Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm getting this problem randomly, since some revisions: Haiku goes to KDL without doing anything in particular. My vmware configuration uses the ipro1000 NIC, the crash seems related to that.

Attachments (6)

Haiku.vmx (3.0 KB) - added by jackburton 12 years ago.
VMWare vmx file
kdl.png (21.8 KB) - added by jackburton 12 years ago.
KDL
teams.PNG (10.3 KB) - added by jackburton 12 years ago.
Teams
kdl2.PNG (11.9 KB) - added by jackburton 12 years ago.
Different KDL, related ?
page_fault.png (16.1 KB) - added by diver 12 years ago.
similar kdl with vmware under linux with vlance driver
serial.txt (128.1 KB) - added by jackburton 12 years ago.
The complete serial log, with backtrace, areas and teams output

Download all attachments as: .zip

Change History (26)

comment:1 Changed 12 years ago by axeld

Component: System/KernelDrivers/Network
Owner: changed from axeld to marcusoverhagen

comment:2 Changed 12 years ago by marcusoverhagen

Status: newassigned

comment:3 Changed 12 years ago by marcusoverhagen

Please attach the vmx file. Might be related to the available memory size.

Do you have any errors like "ipro1000: ERROR get_memory_map failed for 0x8061e802" in syslog or serial debug output before this crash?

comment:4 Changed 12 years ago by marcusoverhagen

This seems to be a kernel bug. I applied a change in hrev19988 that should prevent random crashing in ipro1000. But now you will probably get a panic as described in bug #997.

comment:5 Changed 12 years ago by marcusoverhagen

Resolution: fixed
Status: assignedclosed

Fixed in hrev19992.

Changed 12 years ago by jackburton

Attachment: Haiku.vmx added

VMWare vmx file

comment:6 Changed 12 years ago by jackburton

Resolution: fixed
Status: closedreopened

Reopening, still happens in hrev20005.

comment:7 Changed 12 years ago by marcusoverhagen

Please attach the output of

areas teams

You can setup com1 to go to a file in vmware, and enable serial debug output to capture it.

comment:8 in reply to:  7 Changed 12 years ago by jackburton

Replying to marcusoverhagen:

You can setup com1 to go to a file in vmware, and enable serial debug output to capture it.

Does that work with vmware player too ? I can't find any info on how to redirect the com port.

comment:9 Changed 12 years ago by marcusoverhagen

Yes it works, at least with vmware player in Linux.

serial0.present = "true" serial0.fileType = "file" serial0.fileName = "haiku-serial-port.txt" serial0.tryNoRxLoss = "FALSE"

comment:10 in reply to:  9 Changed 12 years ago by jackburton

Replying to marcusoverhagen:

Now that's interesting. I enabled serial log and the bug isn't showing up anymore.

comment:11 Changed 12 years ago by marcusoverhagen

When reporting additional info, please make sure to include the initally printed KDL information, as the driver has been modified since your initial report.

comment:12 Changed 12 years ago by jackburton

Resolution: fixed
Status: reopenedclosed

I'll close this bug as it no longer applies. I've tried to reproduce it again with newer revisions, but failed.

comment:13 Changed 12 years ago by jackburton

Resolution: fixed
Status: closedreopened

Happens again with latest revision (in VMWare). If I enable syslog I can't reproduce.

Changed 12 years ago by jackburton

Attachment: kdl.png added

KDL

Changed 12 years ago by jackburton

Attachment: teams.PNG added

Teams

comment:14 Changed 12 years ago by jackburton

Actually I'm starting to think it's not related to the ipro1000 driver, since I just reproduced a similar KDL while launching the page setup for the PDF printer driver.

Changed 12 years ago by jackburton

Attachment: kdl2.PNG added

Different KDL, related ?

comment:15 Changed 12 years ago by korli

Out of curiosity, what's your build environment and gcc version ?

Changed 12 years ago by diver

Attachment: page_fault.png added

similar kdl with vmware under linux with vlance driver

comment:16 Changed 12 years ago by jackburton

I was finally able to reproduce it with serial log enabled. It shows up when I mess with ifconfig with the ipro1000 card (trying to set the ip address).

Changed 12 years ago by jackburton

Attachment: serial.txt added

The complete serial log, with backtrace, areas and teams output

comment:17 Changed 12 years ago by jackburton

A side note: I'm having those crashes when connected to a network with many other computers. The large number of "ARP host 1a16a8c0 updated with different hardware address 00:02:a5:93:19:b5." messages could suggest some problems in the net stack itself ?

comment:18 Changed 12 years ago by marcusoverhagen

Does this bug still happen? I can't reproduce it using vmware. I also transefered gigabytes using this driver in BeOS, so I doubt that it's a problem with the driver.

comment:19 in reply to:  18 Changed 12 years ago by jackburton

Replying to marcusoverhagen:

Does this bug still happen? I can't reproduce it using vmware.

I will retest it soon.

I also transefered gigabytes using this driver in BeOS, so I doubt that it's a problem with the driver.

Yes, I have too the feeling it's not a driver problem. Probably it's a kernel/netstack problem which is triggered when the pc is connected to a network with many hosts. In fact, I was also able to reproduce it once with the "other" vmware NIC driver. I will retest it soon, now that the netstack has been changed a lot.

comment:20 Changed 12 years ago by jackburton

Resolution: fixed
Status: reopenedclosed

It's gone. Was probably a bug in the network stack.

Note: See TracTickets for help on using tickets.