Opened 6 years ago

Closed 15 months ago

#9935 closed bug (fixed)

iprowifi4965 fails to connect to NetGear router

Reported by: Pete Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/alpha4.1
Keywords: Cc: harryn@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This problem seems rather different from others reported, such as #9078 or #9694, so I'm opening a new ticket.

I have a laptop with an iprowifi4965 card, and before buying a wifi router for myself, I asked my neigbour if I could test it out on her connection. It worked fine (within the limits of Haiku's current state...). So I went ahead and bought a NetGear Wireless-N 150 router.

Haiku will not connect to this! The laptop is dual-boot Ubuntu/Haiku, and the Linux partition has no problems connecting, but Haiku just goes into a perpetual 'Configuring' state.

Following mmlr's prescription in #9646, I ran net_server from a Terminal and recorded the log, and also extracted the relevant part of the syslog. I'm attaching the logs from both a successful connection to the next-door network, and the failed attempts to link to my own. (The net_server and syslog records are from different sessions -- the syslogs cam first -- but I assume they are comparable.)

The test system is hrev45851, but I have the same symptoms on my normal work partition 44674.

Attachments (4)

net_server_Delia (12.5 KB ) - added by Pete 6 years ago.
net_server record of successful connection
net_server_PansGate (17.3 KB ) - added by Pete 6 years ago.
net_server record of failed connection attempt
syslog_Delia (5.5 KB ) - added by Pete 6 years ago.
syslog segment -- successful connection
syslog_Pansgate (57.0 KB ) - added by Pete 6 years ago.
syslog segment -- failed connection

Download all attachments as: .zip

Change History (22)

by Pete, 6 years ago

Attachment: net_server_Delia added

net_server record of successful connection

by Pete, 6 years ago

Attachment: net_server_PansGate added

net_server record of failed connection attempt

by Pete, 6 years ago

Attachment: syslog_Delia added

syslog segment -- successful connection

by Pete, 6 years ago

Attachment: syslog_Pansgate added

syslog segment -- failed connection

comment:1 by Pete, 6 years ago

I forgot to note that the symptom seems similar to the result of entering a wrong password, which -- even on the 'good' network -- results in a 'Configuring' loop. This doesn't seem right -- surely an error alert or something should appear?

However, I double checked that the password was correct, I even copy/pasted from the router's own configuration screen. And just in case there was something weird with my choice of password, I changed it to the one that works next door. No difference.

comment:2 by tidux, 6 years ago

I've used two different 4965AGN cards with Haiku, and they work fine on both earlier and later releases. I suspect something is wrong with your router.

in reply to:  2 ; comment:3 by polari, 6 years ago

Replying to tidux:

I've used two different 4965AGN cards with Haiku, and they work fine on both earlier and later releases. I suspect something is wrong with your router.

I have the same problem. Haven't confirmed it's identical with syslogs yet but somehow Windows and Linux find a way to connect. It is a terrible router though, no argument there. ;)

comment:4 by polari, 6 years ago

Cc: harryn@… added

in reply to:  3 comment:5 by Pete, 6 years ago

Replying to polari:

Replying to tidux:

I've used two different 4965AGN cards with Haiku, and they work fine on both earlier and later releases. I suspect something is wrong with your router.

A slightly strange definition of "wrong" (:-) Linux (as I said), has absolutely no problem with it (also via the 4965 card), so electrically it's fine. Obviously, though, there is some incompatibility between it and Haiku.

I have the same problem. Haven't confirmed it's identical with syslogs yet but somehow Windows and Linux find a way to connect. It is a terrible router though, no argument there. ;)

What's terrible about it? I have no comparative experience with wireless, but it seemed easy to set up as I wanted. (And I find I can reach it from the back yard (via Linux) as I hoped!) Nice and cheap, though.

comment:6 by tqh, 6 years ago

It seems to be a problem if your password is correct. It fails in authentication:

WPA: 4-Way Handshake failed - pre-shared key may be incorrect

We probably need more details for both networks: What channel, encryption and so on are you using? Is the other network also a 'n' network or an older one like 'g'? Do you use sideband (40MHz mode) or not?

comment:7 by tqh, 6 years ago

Oh, and do you use any characters that is outside of ordinary ASCII in your password?

comment:8 by tqh, 6 years ago

I got emailed a very good review of the logs in Swedish, I hope I can explain it in English:

Good attempt:

150 Mbit HT20 (1 spatial stream@40MHz)

KERN: [net/iprowifi4965/0] [78:ca:39:47:1f:95] switch station to HT20 channel 2417/0x10480
KERN: [net/iprowifi4965/0] [78:ca:39:47:1f:95] AMRR initial rate 72
KERN: [net/iprowifi4965/0] [78:ca:39:47:1f:95] assoc success at aid 1: short preamble, short slot time, QoS, HT20 (+AMPDU)
KERN: [net/iprowifi4965/0] ieee80211_new_state_locked: ASSOC -> RUN (nrunning 0 nscanning 0)
KERN: [net/iprowifi4965/0] ieee80211_newstate_cb: ASSOC -> RUN arg 16
KERN: [net/iprowifi4965/0] sta_newstate: ASSOC -> RUN (16)
KERN: ieee80211_notify_node_join

Bad attempt:

Problems:

  1. Accesspoint asks for EAPOL version 1.
  2. Accesspoint ask to switch to HT40.

HT40 requires two spatial streams (two antennas). HT40 with an accesspoint that only has one antenna probably leads to lost packets, timeout and deauth.

  1. Key length is zero. It may be because of the first problem or bad configuration.
[net/iprowifi4965/0] [00:22:3f:a8:e3:90] switch station to HT40 channel 2427/0x20480
KERN: [net/iprowifi4965/0] [00:22:3f:a8:e3:90] AMRR initial rate 72
KERN: [net/iprowifi4965/0] [00:22:3f:a8:e3:90] assoc success at aid 1: short preamble, short slot time, QoS, HT40 (+AMPDU)
KERN: [net/iprowifi4965/0] ieee80211_new_state_locked: ASSOC -> RUN (nrunning 0 nscanning 0)
KERN: [net/iprowifi4965/0] ieee80211_newstate_cb: ASSOC -> RUN arg 16
KERN: [net/iprowifi4965/0] sta_newstate: ASSOC -> RUN (16)
KERN: ieee80211_notify_node_join
KERN: /dev/net/iprowifi4965/0: media change, media 0x8300af quality 1000 speed 10000000
KERN: [net/iprowifi4965/0] [00:22:3f:a8:e3:90] ieee80211_node_authorize: inact_reload 20
KERN: wlan_control: 9235, 15
KERN: [net/iprowifi4965/0] ieee80211_ref_node (ht_send_action_ba_addba:2378) 0x82ced200<00:22:3f:a8:e3:90> refcnt 4
KERN: /dev/net/iprowifi4965/0: media change, media 0x8600af quality 1000 speed 10000000
...
KERN: [net/iprowifi4965/0] [00:22:3f:a8:e3:90] recv deauthenticate (reason 2)
KERN: [net/iprowifi4965/0] ieee80211_new_state_locked: RUN -> AUTH (nrunning 0 nscanning 0)
KERN: [net/iprowifi4965/0] ieee80211_newstate_cb: RUN -> AUTH arg 704
KERN: [net/iprowifi4965/0] sta_newstate: RUN -> AUTH (704)
KERN: ieee80211_notify_node_leave

Recommended configuration to test:

Supported MCS: MCS0->MCS7 Basic MCS: None selected. Authentication Type: WPA2 Personal (WPA2 PSK). Cipher: AES (not TKIP) Radius: Disabled EAP: Disabled Static keys: None

Also make sure that the configuration in Haiku is correct.

Last edited 6 years ago by tqh (previous) (diff)

in reply to:  8 comment:9 by Pete, 6 years ago

Replying to tqh:

I got emailed a very good review of the logs in Swedish, I hope I can explain it in English:

Thanks for that -- and to whoever did the analysis!

However, our posts crossed, and meanwhile I have actually got the thing working! (I'm posting this via Haiku WiFi.)

The simple fix was to change the default "150Mb/s" to "54Mb/s", and it was able to make the connection.

I have no idea how that relates to the log findings, though. The 'Good' attempt seems to have been using 150Mb, but on Linux, the connection info showed "52Mb" for that net, which was why I changed it.

Good attempt:

150 Mbit HT20 (1 spatial stream@40MHz)

...
KERN: [net/iprowifi4965/0] [78:ca:39:47:1f:95] assoc success at aid 1: short preamble, short slot time, QoS, HT20 (+AMPDU)
...

Bad attempt:

Problems:

  1. Accesspoint asks for EAPOL version 1.
  2. Accesspoint ask to switch to HT40.

HT40 requires two spatial streams (two antennas). HT40 with an accesspoint that only has one antenna probably leads to lost packets, timeout and deauth.

Hah -- I guess that would do it!

...
KERN: [net/iprowifi4965/0] [00:22:3f:a8:e3:90] assoc success at aid 1: short preamble, short slot time, QoS, HT40 (+AMPDU)
...

Strangely. the log now looks a bit different. No reference to either "EAPOL" or either "HT40" or "HT20":

> ...
KERN: [net/iprowifi4965/0] [00:22:3f:a8:e3:90] assoc success at aid 1: short preamble, short slot time, QoS
> ...

Recommended configuration to test:

Supported MCS: MCS0->MCS7 Basic MCS: None selected. Authentication Type: WPA2 Personal (WPA2 PSK). Cipher: AES (not TKIP) Radius: Disabled EAP: Disabled Static keys: None

My Router Configuration pages make no mention of "MCS", "Radius", or "EAP". Not sure what they are, but I guess I can't set them. "Static Keys" are to defeat DHCP for specific MAC address, right? Haven't set any of those at the moment (the router is only a WiFi access point for now, hanging off my actual LAN).

Also make sure that the configuration in Haiku is correct.

Not sure what you mean, here. Network Preferences? This is one of the points of irritation, as it seems to keep changing under me! I'll find that the mode is set to "Static"; I'll change it to "DHCP", click "Apply" and quit the Pref. Then I open it again, and it's back to "Static"!! At the moment it seems to be stable, so I don't know what's triggering it.

Where is that information kept, anyway, if there's no 'interfaces' file? (Having that around definitely causes problems.)

Re your earlier questions, I don't think I know the answers. I suspect the other network is quite likely 'G' rather than 'N', but I have no way of finding out. (As I mentioned elsewhere my neighbour is away for months.) "Channel" is "auto", I think. I guess the "40MHz" is related to the "HT40"?

Thanks again for your quick help.

comment:10 by tqh, 6 years ago

Ah, good. Regarding your questions I can't really give any good answers. I've been stuck in Linux way to long. What I meant by Haiku configuration was just make sure that password and network is set correctly.

It would be interesting to know if there are any faster modes that you can test but still limited to 20MHz. That way we could be a bit more certain that it was 40MHz setting causing the problem.

in reply to:  10 comment:11 by Pete, 6 years ago

Replying to tqh:

It would be interesting to know if there are any faster modes that you can test but still limited to 20MHz. That way we could be a bit more certain that it was 40MHz setting causing the problem.

OK. I've switched to the other option the router gives me: 65 Mb/s. It's still working.

As I've probably mentioned before (:-/), I really know zilch about 802.11 and all its variants, so the 20/40MHz distinction was lost on me. I've been cramming with Wikipedia a bit, so I have a slight grasp now, but I'm still very much newbie. It does sound to me as if the 4965 driver is making some wrong assumptions when trying to use the highest rate, though, as the Linux driver is obviously able to handle it perfectly.

I went back to Ubuntu to check some more. When I had the router set to 150Mb, the connection info showed a maximum of 105Mb, but it tended to fluctuate wildly, dropping to 1Mb at times. Using 65Mb, it showed typically 51Mb, again with variation.

It would be nice if at some point Haiku was able to display that sort of information too. (Though "ifconfig...scan" on Haiku shows signal strength, while I can't find any way of getting that data in Ubuntu. Their ifconfig has quite different options.)

comment:12 by Pete, 6 years ago

I should add that I'm not free of problems yet. After boot I tried to connect, and though it said "Ready" I was not actually connected. A ping of the router gave "Network Unavailable". I disconnected, and re-linked by "ifconfig...join", and this time it worked.

I imagine this is probably a different glitch, though.

comment:13 by Pete, 6 years ago

One more (negative) data point. Being a nice afternoon, I took the laptop into the back yard, where Ubuntu was perfectly able to find my router. Haiku completely failed, though. And when it failed, it would then every time try to connect to "ThunderPussy" (:-/) Dunno why that out of all the nets in range -- must have liked the name...

Worse than that, net_server, NetStatus, and the Deskbar would lock up. So would ifconfig from the Terminal, so the only path was to reboot. I've now removed NetworkStatus from the Deskbar, so that I at least don't lose all functionality. I'll try again outdoors later.

comment:14 by mmadia, 6 years ago

Priority: highnormal

comment:15 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:16 by waddlesplash, 15 months ago

Please retest with a recent build.

comment:17 by Pete, 15 months ago

Sorry -- this ticket seems to have hung about longer than in should have.

As noted above (comment 9), the original problem was fixed by changing the router's default max connection speed. The problems mentioned in comment 13 fade in later revs.

I still have connection death problems -- I lose the link after half-an-hour or so and have to reboot. (My usual rev is not very recent.) I could swear this is covered by another ticket, but I can't find it! I guess this particular ticket is obsolete, though.

comment:18 by waddlesplash, 15 months ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.