Opened 12 years ago

Closed 11 years ago

#1001 closed bug (fixed)

Vision IRC client crashes on close

Reported by: koki Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: anevilyak@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

In revision 19877, the Vision IRC client crashes when you close the program. 100% reproduceable.

For informational purposes, here is some input from Rene Gollent (one of the authors of Vision): "From that stack trace it looks like it's possible that Haiku's BOutlineListView has a bug."

Backtrace attached.

Attachments (1)

bracktrace_vision-crash-on-quit (4.5 KB) - added by koki 12 years ago.
Backtrace

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by koki

Backtrace

comment:1 Changed 12 years ago by jackburton

The backtrace looks very similar to the one in bug #905. They might actually be the same problem.

comment:2 Changed 12 years ago by ketsuban

Platform: Allx86

I've noticed that on R5 if Vision is unable to connect to a server and is closed the windows all quit cleanly, but the application (and its corresponding entry in the Deskbar) hangs about and must be killed through Ctrl-Alt-Del. Is this related? (I'm using hrev20255, by the way.)

comment:3 Changed 12 years ago by ketsuban

Oops, sorry. I typoed; I meant hrev20225, of course.

comment:4 Changed 11 years ago by anevilyak

This issue should be fixed by hrev24139 and hrev24158. With respect to the observed hang on R5, the app is waiting for the server thread attempting the connect() to time out, hence why you still see it there after all windows are closed, since it waits for all the other team threads to exit before terminating. It should normally exit on its own within a reasonable amount of time.

comment:5 Changed 11 years ago by anevilyak

Cc: anevilyak added

comment:6 Changed 11 years ago by anevilyak

Cc: anevilyak@… added; anevilyak removed

comment:7 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.