Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10060 closed bug (fixed)

[WebPositive] Disabling support for SSL certificates, no CA bundle

Reported by: diver Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Package Management
Keywords: Cc:
Blocked By: Blocking: #10128
Has a Patch: no Platform: All

Description

Web+ prints this when started from Terminal:

Disabling support for SSL certificates, no CA bundle in /boot/common/data/ssl.

Locks up when trying to open websites with SSL.

Change History (5)

comment:1 Changed 6 years ago by bonefish

The output I can reproduce with hrev46170. I only tested "https://dev.haiku-os.org/" which works fine, though (no lock-up). The issue is in libwebcore which seems to explicitly look for <B_COMMON_DATA_DIRECTORY>/ssl only.

comment:2 Changed 6 years ago by diver

Blocking: 10128 added

comment:3 Changed 6 years ago by pulkomandy

Owner: changed from bonefish to pulkomandy
Status: newassigned

comment:4 Changed 6 years ago by diver

Resolution: fixed
Status: assignedclosed

Can't reproduce anymore, probably fixed in hrev46371.

comment:5 Changed 6 years ago by pulkomandy

Well, right now there isn't any checking for certificates, which renders SSL useless. I wouldn't consider this fixing the issue...

Note: See TracTickets for help on using tickets.