Opened 6 years ago

Closed 5 years ago

#10069 closed enhancement (no change required)

hpkg: package info in Tracker

Reported by: dsjonny Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: #10236 Blocking:
Has a Patch: no Platform: All

Description

I suggest to add extra attributes and icon to Haiku package file (.hpkg). This can make the package files to be more "userfriendly". The package icon would be the application's icon, and the users can see some package info (the application's name, installed or not, ...) in the Tracker. And it would be useful if the preferred application would be the Haiku Depot. If the user has no internet connection on Haiku, but has packages on an USB drive, it is easy to find out what is that package/file, and just double click on it, and the Haiku Depot opens and install/use it.

Change History (3)

comment:1 Changed 5 years ago by diver

Blocked By: 10236 added
Component: - GeneralApplications/HaikuDepot
Owner: changed from nobody to stippi

Mostly a dupe of #10236.

comment:2 Changed 5 years ago by stippi

How should this work? The package files are downloaded via Package Kit, HaikuDepot just triggers this. Package icons are currently pulled from https://depot.haiku-os.org, but I would find it somehow awkward, if HaikuDepot modifies package file icons after packages have been downloaded. This would also not solve the problem of package files having a better icon when they originate from a USB stick.

Last edited 5 years ago by stippi (previous) (diff)

comment:3 Changed 5 years ago by luroh

Resolution: no change required
Status: newclosed

HaikuDepot is now the default application to open a package and Expander supports viewing the contents of a package. Adding attributes to the hpkg might not be a good idea since those could be lost on non-BFS file systems. Ticket #11665 has some possibly related ideas for Tracker improvements. I am taking the liberty of closing this one.

Note: See TracTickets for help on using tickets.