Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#10236 closed enhancement (fixed)

HPKG Installer app (for local packages)

Reported by: Giova84 Owned by: stippi
Priority: normal Milestone: R1/beta1
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #10069
Has a Patch: no Platform: x86

Description

As suggested by Scott on the mailing list, i open this ticket to submit a GUI app to install local hpkg files:

I made this little and simple app to install local HPKG files, which is based on TrackerScript: https://github.com/HaikuArchives/TrackerScript (which is released under MIT license). Differently from pkgman, this is a GUI app.

So, If core developers think that would be useful improve and/or include this app in Haiku, i attach a zip archive to this ticket, an archive which contain the HPKG file for the installer (move under /boot/home/config/packages), and the modified source code (for now is only possible build this app with gcc2 compiler, but this app properly works under gcc2h Haiku and should also work in gcc4h).

I also guess that this app could be placed under system (to be treated as system apps) by replacing reference, in the source code, from"B_USER_APPS_DIRECTORY" to "B_SYSTEM_APPS_DIRECTORY".

Some screenshots:

http://softwaredepot.xoom.it/HPKG_Installer/Screenshots/HPKG_Installer_I.png http://softwaredepot.xoom.it/HPKG_Installer/Screenshots/HPKG_Installer_II.png http://softwaredepot.xoom.it/HPKG_Installer/Screenshots/HPKG_Installer_III.png

Attachments (2)

HPKG_Installer-1.0.0.zip (115.6 KB) - added by Giova84 6 years ago.
HPKG_Installer-1.0.0-Rev2.zip (115.5 KB) - added by Giova84 6 years ago.
Revision 2

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by Giova84

Attachment: HPKG_Installer-1.0.0.zip added

comment:1 Changed 6 years ago by Giova84

I upload revision 2 with some improvements about mime type

Last edited 6 years ago by Giova84 (previous) (diff)

Changed 6 years ago by Giova84

Revision 2

comment:2 Changed 6 years ago by humdinger

I wonder if it weren't a better idea to open hpkgs with HaikuDepot:

  • It starts fast enough (should be even faster when it doesn't have to load a remote repository)
  • It shows the summary/description of the package
  • It shows links to the project website
  • In the future it may run some security and integrity checks

comment:3 Changed 5 years ago by waddlesplash

Component: Applications/PackageInstallerKits/Package Kit
Milestone: R1R1/alpha5
Owner: changed from sil2100 to bonefish

comment:4 Changed 5 years ago by diver

Maybe PackageInstaller could be adapted to do that? This way it will handle both BeOS and Haiku packages and the name fits perfectly ;-)

comment:5 Changed 5 years ago by waddlesplash

Component: Kits/Package KitApplications/HaikuDepot
Owner: changed from bonefish to stippi

No, actually I now think is a job for HaikuDepot.

I think the correct way to do this is to have a pop-up dialog that's basically the lower panel of HaikuDepot (like GDebi is on Ubuntu) and have the same "Install" button there.

comment:6 Changed 5 years ago by stippi

I agree that it should be part of HaikuDepot. The package info area has quite a lot of code that doesn't need duplication. There are other ways of avoiding duplication, but I don't see why HaikuDepot should not simply run in a different mode when launched this way. Also, to extract information from a package file, I believe the tool needs to be a C++ app linking against Package Kit.

comment:7 Changed 5 years ago by waddlesplash

@stippi With your recent changes, this can probably be closed. However, it'd be nice to have HaikuDepot be set as the default app for HPKGs, can you do that?

comment:8 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: newclosed

comment:9 Changed 5 years ago by diver

Blocking: 10069 added

(In #10069) Mostly a dupe of #10236.

comment:10 Changed 5 years ago by pulkomandy

Milestone: R1/alpha5R1/beta1
Note: See TracTickets for help on using tickets.