Opened 6 years ago

Closed 4 years ago

#10080 closed enhancement (fixed)

Shortcuts won't launch a script

Reported by: dsuden Owned by: nobody
Priority: normal Milestone: R1
Component: Preferences/Shortcuts Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

With a script as follows:

#!/bin/sh

alert blah

If marked executable and saved in /boot/home/config/bin, I can run it successfully by double-clicking it or running it from Terminal. But if I assign a shortcuts key combination to it, it will not run.

Note, shortcuts is running fine for me in 40633, for launching apps...it just won't launch a script.

Change History (6)

comment:1 by ttcoder, 6 years ago

Component: User InterfacePreferences/Shortcuts
Owner: changed from stippi to nobody
Type: bugenhancement

a bit of properties fine-tuning =)

comment:2 by humdinger, 6 years ago

hrev40633 is quite old. As reported in #9958, Shortcuts don't work at all (at least for me with currently hrev46198). Duplicate this?

comment:3 by ttcoder, 6 years ago

Sorry, dsuden likely meant hrev46033, which we use in production for now. In addition to our technical problem with lameenc/HaikuPM I'm working on soothing dsuden's frowning at the whole concept of package management to begin with ;-) Once he buys my spiel that it has more benefits than drawbacks and I convince him of spending time in 46198 (and more recent ones) he should try out the workaround found by Giova84 in #9958 to verify that that ticket is distinct from this ticket/enhancement, which it seems to be. Heck, I might even try and lend a hand (look at the code for both tickets) if I finish my chores soon enough.. maybe in a few weeks.

comment:4 by dsuden, 4 years ago

I think this can retire...no longer experiencing this at all.

comment:5 by Janus, 4 years ago

I can't reproduce it. Retire this as dusden asked.

comment:6 by waddlesplash, 4 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.