Opened 6 years ago

Closed 6 years ago

#10108 closed bug (fixed)

[HaikuDepot] duplicate packages

Reported by: Giova84 Owned by: anevilyak
Priority: normal Milestone: R1
Component: Servers/package_daemon Version: R1/Development
Keywords: HaikuDepot duplicate packages Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Yesterday i needed to install the package "openssl_x86_devel-1.0.0j-4-x86_gcc2.hpkg" (to build TOR), so i start HaikuDepot to install this package. Once was installed, an alert told me that also the packages "openssl-1.0.0j-4-x86_gcc2.hpkg" and "openssl_x86-1.0.0j-4-x86_gcc2.hpkg" were required, to install the devel package. So, to be sure to properly set the environment, i agreed. And i've seen that these three packages was installed under /config/packages But then i noticed that "openssl-1.0.0j-4-x86_gcc2.hpkg" and "openssl_x86-1.0.0j-4-x86_gcc2.hpkg" (proposed packages) were already present under /system/packages. To keep all clear i have moved "openssl_x86_devel-1.0.0j-4-x86_gcc2.hpkg" to /system/packages and all works fine in anyway.

hrev46239

Change History (3)

comment:1 by diver, 6 years ago

Component: Applications/HaikuDepotServers/package_daemon
Owner: changed from stippi to bonefish
Status: newassigned

comment:2 by bonefish, 6 years ago

Owner: changed from bonefish to anevilyak

When installing a openssl_devel package in home, the openssl package has to be installed there as well. So the behavior is correct as such. HaikuDepot shouldn't install packages in home by default, though.

in reply to:  2 comment:3 by anevilyak, 6 years ago

Resolution: fixed
Status: assignedclosed

Replying to bonefish:

When installing a openssl_devel package in home, the openssl package has to be installed there as well. So the behavior is correct as such. HaikuDepot shouldn't install packages in home by default, though.

Location adjusted in hrev46250.

Note: See TracTickets for help on using tickets.