Opened 13 years ago

Closed 12 years ago

#1012 closed bug (duplicate)

GUI doesn't redraw after starting Cortex

Reported by: marcusoverhagen Owned by: marcusoverhagen
Priority: high Milestone: R1
Component: Kits/Media Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When starting Cortex, it's window doesn't show up.

All active windows stop redrawing, including Desktop, Deskbar, Terminal and Tracker. It's still possible to move windows.

Tested hrev20060 using vmware, reproduceable.

Change History (3)

comment:1 by mmu_man, 13 years ago

Cortex seems to lock everything up here too, hrev20058 in qemu. Will test no real hw.

comment:2 by axeld, 12 years ago

Component: - User InterfaceKits/Media Kit
Owner: changed from axeld to marcusoverhagen

There must be something very wrong with the scheduler, at least hrev20427 fixed the issue for me. What actually happens is that the "System Clock control" thread runs at 100% - it's either bombardized with messages, or there is something wrong. I'm therefore changing components.

comment:3 by marcusoverhagen, 12 years ago

Resolution: duplicate
Status: newclosed

this is a duplicate of bug #731

Note: See TracTickets for help on using tickets.