Opened 6 years ago

Closed 6 years ago

#10125 closed bug (fixed)

ScreenSaver locks up

Reported by: bbjimmy Owned by: jscipione
Priority: normal Milestone: R1
Component: Preferences/ScreenSaver Version: R1/Development
Keywords: Cc:
Blocked By: #4260 Blocking:
Has a Patch: no Platform: All

Description

On Haiku hrev 46271 the ScreenSaver prefflet locks up the second time it is launched. It has to be killed. This will continue unless one deletes the ~/config/settings/ScreenSaver_settings file. Then the prefflet will launch normally.

Attachments (1)

bitmap.png (50.2 KB ) - added by bbjimmy 6 years ago.
screenshot

Download all attachments as: .zip

Change History (6)

by bbjimmy, 6 years ago

Attachment: bitmap.png added

screenshot

comment:1 by diver, 6 years ago

Owner: changed from axeld to jscipione
Status: newassigned

comment:2 by jscipione, 6 years ago

Blocked By: 4260 added

comment:3 by bbjimmy, 6 years ago

This doesn't appear to be thesame bug. I can open the ScreenSaver preflet and change settings including selecting a screensver then quit, everything appears to work fine, but on the secod launch, it cannot paint the window and will not quit. deleting the settings file seems to reset things and the preflet opens again without problems. on the next launch, however, the problem returns.

comment:4 by jscipione, 6 years ago

It's not the same bug, that's why I didn't close the ticket as a duplicate but it is caused by the same underlying issue which is a race condition in the window and renderer threads. I had a work around in place that made the issue much less severe but I was pressured to revert it.

comment:5 by jscipione, 6 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev46368 and hrev46374

Note: See TracTickets for help on using tickets.