Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#1015 closed bug (fixed)

BListView invokes on single-click when item is already selected (easy)

Reported by: wkornewald Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Mouse/PS2 Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I saw this behavior with the attributes and extensions lists in FileTypes. You select an item and then you can always invoke it with one single click.

I don't know if the problem is in input_server, the mouse driver, BListView, or FileTypes. :)

Change History (5)

comment:1 by wkornewald, 12 years ago

Summary: BListView invokes on single-click when item is already selectedBListView invokes on single-click when item is already selected (easy)

comment:2 by axeld, 12 years ago

I can't reproduce this (tested with Qemu) - can you still do so? And if that is the case, on real hardware or using an emulator (and which one)?

comment:3 by wkornewald, 12 years ago

Yep, reproduceable under VMware with hrev21543. Just select "audio" and then under "extended attributes" select an attribute, wait a few seconds, then click on the selected element again. The edit window will open.

comment:4 by axeld, 12 years ago

Component: - Preferences/FileTypesDrivers/Mouse/PS2
Resolution: fixed
Status: newclosed

Thanks for the update! It's now fixed in hrev21544. The important but missing bit of information was that it only happened when you actually kept moving the mouse while waiting - at least over here; please retest.

comment:5 by wkornewald, 12 years ago

Works perfectly! Thanks!

Note: See TracTickets for help on using tickets.