Opened 7 years ago

Closed 7 years ago

#10172 closed bug (fixed)

[NetworkStatus] use the network kit api

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: Applications/NetworkStatus Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

This is hrev46311.

Probably the same changes should be applied to NetworkStatus as in hrev45534 since it shows bogus values while interface is configuring.

Change History (7)

comment:1 by diver, 7 years ago

To reproduce use non-existent interface: ifconfig /dev/net/foo auto-config

Last edited 7 years ago by diver (previous) (diff)

comment:2 by jackburton, 7 years ago

Status: newin-progress

comment:3 by jackburton, 7 years ago

Done in hrev46328. Unfortunately this does not fix the problem reported in comment 1.

in reply to:  3 comment:4 by jackburton, 7 years ago

Replying to jackburton:

Done in hrev46328. Unfortunately this does not fix the problem reported in comment 1.

Replying to myself: The problem lies within BNetworkRoster or, more probably, in the network stack: BNetworkRoster::AddInterface() should fail when passing an invalid interface like in comment 1.

comment:5 by jackburton, 7 years ago

As suspected: ifconfig /dev/net/foo does actually cause the net_stack to allocate resources for the non-existing interface.

comment:6 by jackburton, 7 years ago

Shouldn't the stack or the ethernet module check if a device with the given name exists ? In allocate_device_interface() or in ethernet_init() respectively.

comment:7 by jackburton, 7 years ago

Resolution: fixed
Status: in-progressclosed

Closing, since the original problem is fixed. I opened a new ticket for the problem in comment 1. (#10183).

Note: See TracTickets for help on using tickets.