Opened 6 years ago

Closed 3 years ago

#10173 closed enhancement (fixed)

Spurious alert box when working in /tmp ("careful, this is a system folder")

Reported by: ttcoder Owned by: waddlesplash
Priority: normal Milestone: Unscheduled
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If you open the (normally hidden from Tracker view) /tmp folder with open /tmp or by expanding an archive there ..etc, and rename one of its files, or drag'n'drop one of its files out of it, as of recent (PM) Haiku builds you will get the "this is a system folder, are you sure to change it, press <Shift> to go ahead" alert box.

In all likelyhood this is due to /tmp having relocated from /boot/common/cache/tmp (where Tracker knows not to alert the user) to /boot/system/.../tmp.

Filing as enhancement as my usage pattern is probably pretty obscure (I do a lot of work in /tmp with files that are temporary and I don't want to survive a reboot / not have to remember to move to Trash), though technically this is a regression/bug.

Summary: Tracker should make an exception to the rule and consider the /tmp part of /boot/system is not a folder that needs protection, by opposed to, say, the add-ons or kernel/drivers folders.

Change History (4)

comment:1 by ttcoder, 6 years ago

This is the one I hit all the time:

http://cgit.haiku-os.org/haiku/tree/src/kits/tracker/FSUtils.cpp#n640

Before proposing a one-liner patch I'll check the code upstream a bit, but it seems that it is indeed within this function that lays the responsibility for including/excluding folders.

comment:2 by waddlesplash, 5 years ago

Milestone: R1Unscheduled

comment:3 by waddlesplash, 5 years ago

Owner: changed from axeld to waddlesplash
Status: newassigned

comment:4 by waddlesplash, 3 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev50463.

Note: See TracTickets for help on using tickets.