Opened 6 years ago

Closed 6 years ago

#10196 closed bug (fixed)

Installer crash at main window startup while scanning partitions

Reported by: oco Owned by: bonefish
Priority: high Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

With Haiku's nightly image hrev46353 (ISO flavor), i have a crash while scanning partitions (see attached bug report).

It is in VirtualBox. The only other disk is a newly created fixed drive with nothing inside.

Attachments (2)

Installer-189-debug-11-11-2013-16-04-48.report (18.3 KB ) - added by oco 6 years ago.
syslog (57.7 KB ) - added by oco 6 years ago.

Download all attachments as: .zip

Change History (10)

by oco, 6 years ago

Attachment: syslog added

comment:1 by oco, 6 years ago

After some more testing with older revisions from Haiku-files, hrev46335 is ok on this same test case.

comment:2 by kallisti5, 6 years ago

Priority: normalhigh

Seeing the same crash using the x86_gcc2h vmdk image (hrev46353).

No recent code changes to installer.

comment:3 by anevilyak, 6 years ago

Cc: bonefish added

The only commit in the range of hrev46335 and hrev46353 that looks like it has any potential to affect this is http://cgit.haiku-os.org/haiku/commit/?id=18640f2 , but from a glance I'm not completely certain as to how/why that'd be the case.

comment:4 by diver, 6 years ago

df also look a bit odd now. And I have no tab title at all if I open Haiku volume from the Desktop.

comment:5 by anevilyak, 6 years ago

Cc: bonefish removed
Component: Applications/InstallerSystem/Kernel
Owner: changed from korli to bonefish
Status: newassigned

commit 18640f2 confirmed thanks to diver.

comment:6 by bonefish, 6 years ago

Status: assignedin-progress

Seems to be gcc2 only. Will have a look.

comment:7 by bonefish, 6 years ago

Fixed in hrev46359.

comment:8 by bonefish, 6 years ago

Resolution: fixed
Status: in-progressclosed
Note: See TracTickets for help on using tickets.