Opened 5 years ago

Closed 5 years ago

#10252 closed bug (duplicate)

reproducible Web+ crash on specific URL

Reported by: Kev Owned by: pulkomandy
Priority: high Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

On hrev46447, if I open Web+ and immediately go to http://search.capebretonrealty.com/listing/p-5-salem-rd--enon-15781545 and wait for about 30 seconds for it to try to finish loading, I get such a crash that choosing "Save Report" pegs the Debugger's "worker" thread for a long time until I kill it, having produced a 45 MB debug report up to that point. I can't even open the report in StyledEdit, which then also pegs and becomes unresponsive after about 30 seconds.

Undoubtedly the page at that URL is not the leanest in the world, but I can at least load it on Firefox/Win7 on a mid-range laptop without it bringing the browser or computer down or even kicking the CPU fans into high gear, so I don't think it has an infinite loop issue.

The bulk of it, if I cat the file, looks like the first section of the output below:

~/Desktop> tail -n 90 WebPositive-1210-debug-26-11-2013-17-02-22.report 
                0x63554b48      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554b88      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554bc8      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554c08      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554c48      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554c88      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554cc8      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554d08      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554d48      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554d88      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554dc8      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554e08      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554e48      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554e88      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554ec8      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554f08      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554f48      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554f88      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63554fc8      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63555008      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63555048      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63555088      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x635550c8      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63555108      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63555148      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63555188      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x635551c8      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63555208      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47
                0x63555248      0x1ab1017       WebCore::Image::draw(WebCore::GraphicsContext*, WebCore::FloatRect const&, WebCore::FloatRect const&, WebCore::ColorSpace, WebCore::CompositeOperator, WebCore::BlendMode, WebCore::ImageOrientationDescription) + 0x47

                Registers:
                          eip:  0x01ab0fe2
                          esp:  0x62952fd0
                          ebp:  0x62953008
                          eax:  0x00000000
                          ebx:  0x02b039c0
                          ecx:  0x071e3630
                          edx:  0x00000001
                          esi:  0x02aeed48
                          edi:  0x071e3630
                           cs:  0x001b
                           ds:  0x0023
                           es:  0x0023
                           fs:  0x005b
                           gs:  0x0023
                           ss:  0x0023

Loaded Images:
        ID              Text Base       Text End        Data Base       Data EnType     Name
        --------------------------------------------------------------------------------
        5328    0x0032e000      0x0044b000      0x0044b000      0x00452000     lib      /boot/system/lib/x86/libxml2.so.2.8.0
        5327    0x005f6000      0x006cb000      0x006cb000      0x0070c000     lib      /boot/system/lib/x86/libroot.so
        5343    0x00a90000      0x00aa5000      0x00aa5000      0x00aa8000     lib      /boot/system/lib/x86/libsupc++.so
        5321    0x00acc000      0x00ba1000      0x00ba1000      0x00bad000     lib      /boot/system/lib/x86/libstdc++.so
        5340    0x00bba000      0x00beb000      0x00beb000      0x00bec000     lib      /boot/system/lib/x86/libicule.so.48.1.1
        5322    0x00bef000      0x00e88000      0x00e88000      0x00e9f000     lib      /boot/system/lib/x86/libbe.so
        5336    0x00ea4000      0x00ea8000      0x00ea8000      0x00ea9000     lib      /boot/system/lib/x86/libbsd.so
        5326    0x00eae000      0x00ec0000      0x00ec0000      0x00ec2000     lib      /boot/system/lib/x86/libtranslation.so
        5346    0x00ec6000      0x00ed6000      0x00ed6000      0x00ed7000     lib      /boot/system/lib/x86/libroot-addon-icu.so
        5341    0x00ef8000      0x00f01000      0x00f01000      0x00f03000     lib      /boot/system/lib/x86/libiculx.so.48.1.1
        5318    0x00f0e000      0x00f2b000      0x00f2b000      0x00f2e000     lib      /boot/system/runtime_loader
        5342    0x00f37000      0x00f55000      0x00f55000      0x00f89000     lib      /boot/system/lib/x86/libicutu.so.48.1.1
        5339    0x00fae000      0x00fb6000      0x00fb6000      0x00fb8000     lib      /boot/system/lib/x86/libicuio.so.48.1.1
        5330    0x011f4000      0x01217000      0x01217000      0x01218000     lib      /boot/system/lib/x86/libpng15.so.15.12.0
        5329    0x01517000      0x015ad000      0x015ad000      0x015b0000     lib      /boot/system/lib/x86/libsqlite3.so.0.8.6
        5319    0x015d3000      0x01637000      0x01637000      0x0163c000     app      /boot/system/apps/WebPositive
        5320    0x01666000      0x02a58000      0x02a58000      0x02b18000     lib      /boot/system/lib/x86/libWebKit.so.1.2.0
        5335    0x02b1c000      0x02b33000      0x02b33000      0x02b34000     lib      /boot/system/lib/x86/libz.so.1.2.8
        5331    0x02b36000      0x02b71000      0x02b71000      0x02b73000     lib      /boot/system/lib/x86/libjpeg.so.9.0.0
        5324    0x02b7d000      0x02bc0000      0x02bc0000      0x02bc2000     lib      /boot/system/lib/x86/libbnetapi.so
        5345    0x02bcf000      0x02c13000      0x02c13000      0x02c17000     lib      /boot/system/lib/x86/libssl.so.1.0.0
        5334    0x02c41000      0x02c74000      0x02c74000      0x02c76000     lib      /boot/system/lib/x86/libxslt.so.1.1.28
        5325    0x02c7a000      0x02df9000      0x02df9000      0x02e08000     lib      /boot/system/lib/x86/libtracker.so
        5323    0x02e1a000      0x02e5d000      0x02e5d000      0x02e60000     lib      /boot/system/lib/x86/libnetwork.so
        5333    0x02eb6000      0x02ff0000      0x02ff0000      0x02ffe000     lib      /boot/system/lib/x86/libicuuc.so.48.1.1
        5332    0x03024000      0x031d7000      0x031d7000      0x031e0000     lib      /boot/system/lib/x86/libicui18n.so.48.1.1
        5344    0x0360c000      0x0373b000      0x0373b000      0x03751000     lib      /boot/system/lib/x86/libcrypto.so.1.0.0
        5337    0x03965000      0x03a5c000      0x03a5c000      0x03a5e000     lib      /boot/system/lib/x86/libtextencoding.so
        5338    0x04059000      0x051f4000      0x051f4000      0x051fa000     lib      /boot/system/lib/x86/libicudata.so.48.1.1
        5317    0x610bb000      0x610c3000      0x00000000      0x00000000     system   commpage

Areas:
        ID              Base            End                     Size (KiB)     Protection       Locking                 Name
        --------------------------------------------------------------------------------

Protection Flags: r - read, w - write, x - execute, s - stack, o - overcommit, c - cloneable, S - shared, k - kernel

Semaphores:
        ID              Count   Last Holder     Name
        ------------------------------------------------------------
~/Desktop> 

Protection Flags: r - read, w - write, x - execute, s - stack, o - overcommit, c - cloneable, S - shared, k - kernel

Semaphores:
        ID              Count   Last Holder     Name
        ------------------------------------------------------------
~/Desktop>

Change History (1)

comment:1 Changed 5 years ago by pulkomandy

Resolution: duplicate
Status: newclosed

Duplicate of #10213.

Note: See TracTickets for help on using tickets.