Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1027 closed bug (invalid)

Trash icon sometimes fails to update after clearing it of items

Reported by: ketsuban Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Sometimes when clearing the Trash it fails to update the icon. The icon must be rightclicked and then swept over in some way so as to force it to be redrawn in order to restore the correct empty icon. I have been unable to ascertain what causes this to happen.

This behaviour was also present in the version of Tracker released with BeOS R5.

Change History (4)

comment:1 Changed 12 years ago by ketsuban

Okay, I've realised this is a stupid, stupid report caused by me not checking rigorously enough. Could someone close this as not-a-bug?

comment:2 Changed 12 years ago by korli

Resolution: invalid
Status: newclosed

comment:3 Changed 12 years ago by jonas.kirilla

I've seen this for years in BeOS, so I had a quick look at TrashWatcher.cpp.

I'm testing the latest Haiku OpenTracker on BeOS/Bone, where I've set BTrashWatcher to run at B_NORMAL_PRIORITY instead of B_LOW_PRIORITY. Just a shot in the dark.

Formally, would it be okay for me to reopen this ticket?

comment:4 Changed 12 years ago by axeld

If you are experiencing this bug under Haiku, yes, of course. If you only know it from BeOS, then no. Haiku is supposed to deliver node monitor messages in a much more sane and safer way than R5 did.

IOW this problem shouldn't exist under Haiku. It's not a problem of the Tracker code, it's a problem of BeOS losing messages.

Note: See TracTickets for help on using tickets.