Opened 6 years ago

Closed 6 years ago

#10320 closed bug (fixed)

HSBC website does not load.

Reported by: arfonzo Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Web+ HSBC Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

http://hsbc.co.uk http://hsbc.co.uk/1/2

When you access these sites, and hit the "Log On" button in the top right, you get source code shown instead of rendered HTML (the HSBC site seems to generate content type text/plain for unknown browsers).

When you then try to go back to HSBC's landing page, that also renders as plaintext now. The source shows the content type here as text/html.

Tested on hrev46543.

Change History (2)

comment:1 Changed 6 years ago by pulkomandy

I can reproduce, but I have no idea what is going on. A network capture (at HTTP level) of another browser connecting to the website would be helpful, but they enforce https so that may not be easy to get.

The fact that you get to a page showing the sourcecode is irrelevant, it seems HSBC error page is served with the wrong content-type. The problem is we get served that page instead of what we asked in the first place.

Trying to load the homepage again fails with the same error page, which hints to an error in our cookie management, but I can't spot anything obviously wrong with it.

comment:2 Changed 6 years ago by pulkomandy

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.