Opened 6 years ago

Closed 4 years ago

#10439 closed bug (fixed)

middle click causes crash in BColumn

Reported by: mmadia Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #10740
Has a Patch: yes Platform: All

Description

hrev46705 gcc2h.

Upon opening HaikuDepot, middle clicking any column will result in the attached crash.

Upon opening, left clicking any list (to adjust its sorting) will result in the middle click effectively being ignored, but not crashing.

Furthermore, manually resizing a column via a left click will allow middle click to work as expected.

Attachments (2)

Change History (10)

comment:1 by anevilyak, 6 years ago

Component: Applications/HaikuDepotKits/Interface Kit
Owner: changed from stippi to axeld

That looks like a problem in BColumnListView.

comment:2 by kallisti5, 6 years ago

Milestone: R1R1/alpha5

comment:3 by diver, 5 years ago

Blocking: 10740 added

(In #10740) Indeed. Thanks!

comment:4 by Kev, 5 years ago

Confirmed on hrev47114.

comment:5 by diver, 5 years ago

Milestone: R1/alpha5R1

comment:6 by Janus, 4 years ago

Has a Patch: set

comment:7 by Janus, 4 years ago

Fixed in hrev48988.

comment:8 by waddlesplash, 4 years ago

Resolution: fixed
Status: newclosed

@Janus: did Oliver grant you ticket-modify permissions yet? If not, maybe give him a poke on email...

Note: See TracTickets for help on using tickets.