Opened 5 years ago

Closed 5 years ago

#10740 closed bug (duplicate)

[Sounds] crashes in BColumn::MinWidth(BColumn)

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: #10439 Blocking:
Has a Patch: no Platform: All

Description

This is hrev47102.

Opening Sounds (or any other app which uses BColumnListView) and middle clicking column separator crashes the app.

state: Exception (Segment violation)

Frame		IP			Function Name
-----------------------------------------------
0x795c30d0	0x9494be	BColumn::MinWidth(BColumn) + 0x6
	Disassembly:
		BColumn::MinWidth(BColumn):
		0x009494b8:               55  push %ebp
		0x009494b9:             89e5  mov %esp, %ebp
		0x009494bb:           8b4508  mov 0x8(%ebp), %eax
		0x009494be:           d94004  fld 0x4(%eax) <--

	Frame memory:
		[0x795c30c8]  .1\yQ...   a8 31 5c 79 51 e2 94 00
0x795c31b0	0x94e24c	BPrivate::TitleView::ResizeSelectedColumn(BPoint, bool) + 0x28
0x795c3260	0x9500a2	BPrivate::TitleView::MouseDown(BPoint) + 0x55a
0x795c3460	0x7d1bfd	BWindow::DispatchMessage(BMessage*, BHandler*) + 0xf49
0x795c3490	0x947cb4	HWindow::DispatchMessage(BMessage*, BHandler*) + 0x38
0x795c34f0	0x7d6a4a	BWindow::task_looper() + 0x28e
0x795c3520	0x6f36bd	BLooper::_task0_(void*) + 0x3d
0x795c3548	0x1afc621	thread_entry + 0x21
00000000	0x604cc250	commpage_thread_exit + 0

Attachments (1)

Sounds-1501-debug-08-04-2014-11-03-50.report (10.2 KB) - added by diver 5 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 5 years ago by KapiX

This issue is duplicate of #10439.

comment:2 Changed 5 years ago by diver

Blocked By: 10439 added
Resolution: duplicate
Status: newclosed

Indeed. Thanks!

Note: See TracTickets for help on using tickets.