Opened 6 years ago

Closed 8 weeks ago

#10477 closed bug (invalid)

Single pixel line on hp mini note (netbook) display

Reported by: 6foot3 Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Drivers/Graphics/intel_extreme/9xx Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Between hrev46656 and hrev46726 intel extreme driver starts showing a single pixel height line instead of the 1024x600 native resolution of the hardware. On an Asus EeePC the vesa driver is used so the problem does not show. I am submitting this ticket using the Asus so, I will attach the lisdev output from this harware and the boot up the HP and attach the listdev output and syslog from the HP.

Attachments (7)

Asus_listdev_output.txt (2.5 KB ) - added by 6foot3 6 years ago.
hp_listdev_output.txt (2.4 KB ) - added by 6foot3 6 years ago.
hp_listdev_output.2.txt (2.4 KB ) - added by 6foot3 6 years ago.
intel_extreme_driver_load_syslog.txt (9.7 KB ) - added by 6foot3 6 years ago.
vesa_driver_load_syslog.txt (3.1 KB ) - added by 6foot3 6 years ago.
r46684 syslog.txt (11.6 KB ) - added by 6foot3 6 years ago.
r46699 syslog (12.5 KB ) - added by 6foot3 6 years ago.

Download all attachments as: .zip

Change History (17)

by 6foot3, 6 years ago

Attachment: Asus_listdev_output.txt added

by 6foot3, 6 years ago

Attachment: hp_listdev_output.txt added

by 6foot3, 6 years ago

Attachment: hp_listdev_output.2.txt added

by 6foot3, 6 years ago

Attachment: vesa_driver_load_syslog.txt added

comment:1 by pulkomandy, 6 years ago

It would be very nice if you could try more nightlies between these two versions to reduce the commit range. http://www.haiku-files.org/haiku/development/

Trying hrev46699 and hrev46684 would help, as hrev46694 may be the problem.

by 6foot3, 6 years ago

Attachment: r46684 syslog.txt added

by 6foot3, 6 years ago

Attachment: r46699 syslog added

in reply to:  1 comment:2 by 6foot3, 6 years ago

Replying to pulkomandy:

It would be very nice if you could try more nightlies between these two versions to reduce the commit range. http://www.haiku-files.org/haiku/development/

Trying hrev46699 and hrev46684 would help, as hrev46694 may be the problem.

Downloaded and tried. Works with hrev46684 and fails with hrev46699. I'm attaching the syslogs for both.Like you I suspected that hrev46694 is the problem as I follow the commits log looking out for any changes that affect the hardware on this netbook, in particular any changes to the intel extreme driver or hda diriver (audio is still not yet working on this netbook). This particular issue with the display might be a regression since there was a similar bug that existed with several intel graphics chipsets IIRC. I don't remember who fixed it. It might have been Axel.

Edit: fails with hrev46699 and not hrev46694. There was no nightly build named hrev46694.

Last edited 6 years ago by 6foot3 (previous) (diff)

comment:3 by luroh, 6 years ago

Blocking: 7665 added

comment:4 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:5 by waddlesplash, 17 months ago

Keywords: boot-failure added; single pixel line removed

comment:6 by waddlesplash, 17 months ago

Blocking: 7665 removed

comment:7 by pulkomandy, 14 months ago

Milestone: R1R1/beta2

comment:8 by waddlesplash, 8 months ago

Please retest after hrev53040.

comment:9 by pulkomandy, 2 months ago

Component: Drivers/Graphics/intel_extremeDrivers/Graphics/intel_extreme/9xx

comment:10 by waddlesplash, 8 weeks ago

Resolution: invalid
Status: assignedclosed

No reply.

Note: See TracTickets for help on using tickets.