Opened 5 years ago

Closed 5 years ago

Last modified 13 months ago

#10558 closed bug (fixed)

Haiku goes into reboot loop

Reported by: vidrep Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tried to install alpha 4.1 to hard drive partition from CD Tried to install hrev46791 to hard drive partition from USB PC goes into continuous startup loop Tried Zeta 1.21, BSD and Linux All successfully booted Attached listdev obtained from Zeta install and PC specification.

Attachments (2)

listdev_Zeta (10.7 KB) - added by vidrep 5 years ago.
HP dc7700 sff.pdf (1.4 MB) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (20)

Changed 5 years ago by vidrep

Attachment: listdev_Zeta added

Changed 5 years ago by vidrep

Attachment: HP dc7700 sff.pdf added

comment:1 Changed 5 years ago by jackburton

I have some of these machines where I work. I could try booting Haiku on one.

comment:2 Changed 5 years ago by luroh

Blocking: 7665 added

comment:3 Changed 5 years ago by vidrep

Tried again using hrev47847. Problem still exists. Experimented with BeOS R5, BeOS Dano, Zeta 1.21, and some old Haiku builds. R5 and Dano install CD's only boot to the second icon. Zeta boots and installs the OS to the hard drive without any problems. Only Haiku exhibits the problem described above, where the PC goes into a continuous startup loop. Previously I had also experimented with BSD, Linux and Windows, and none of those had this issue.

Last edited 5 years ago by vidrep (previous) (diff)

comment:4 Changed 5 years ago by diver

Please attach your syslog.

comment:5 Changed 5 years ago by vidrep

The boot sequence never gets beyond "Attempting to boot from CDROM...". The problem occurs before the splash screen appears. I have attempted to log the serial output during boot. However, there is no data in he file.

comment:6 Changed 5 years ago by jessicah

Can you confirm the BIOS settings? Especially the IDE emulation mode. And whether using AHCI or IDE Legacy works. The names might be slightly off, been a while since I've worked with this particular model. But I've never had issues booting Haiku off HP hardware in the past.

comment:7 Changed 5 years ago by vidrep

I went into the BIOS settings and can confirm SATA is in IDE emulation mode. There is no provision in the BIOS to set AHCI - it is either IDE or RAID. I tried both without success. Like you, this is the first HP product I have had booting issues with. I just find it strange that everything except Haiku will boot on this PC.

comment:8 Changed 5 years ago by axeld

Our ATA stack isn't as forgiving as other implementations. There were quite a number of problems when we switched from the former IDE bus manager. Not sure if that one still builds, but if it does, it would be worth a try.

comment:9 in reply to:  1 ; Changed 5 years ago by vidrep

Replying to jackburton:

I have some of these machines where I work. I could try booting Haiku on one.

Did you ever get a chance to try booting Haiku on one of your machines?

comment:10 Changed 5 years ago by vidrep

Tried the latest nightly hrev48147 using cd ISO and USB Anyboot. It still goes into a continuous boot loop - never getting to the splash screen. I was hoping to use this PC as another Haiku test platform when I purchased it. I find it strange that every other operating system except Haiku boots without a problem, including BSD, Linux, Solaris, Windows and BeOS.

comment:11 Changed 5 years ago by vidrep

Summary: Haiku no boot on HP dc7700 sff PCHaiku goes into reboot loop

comment:12 Changed 5 years ago by diver

Component: - GeneralSystem/Boot Loader
Owner: changed from nobody to axeld

comment:13 in reply to:  9 Changed 5 years ago by jackburton

Replying to vidrep:

Replying to jackburton:

I have some of these machines where I work. I could try booting Haiku on one.

Did you ever get a chance to try booting Haiku on one of your machines?

Nope. Unfortunately the only machines of that kind we have are all still in production. I could maybe do that in 2015.

comment:14 Changed 5 years ago by jackburton

Resolution: fixed
Status: newclosed

Today I tried booting a nightly on an HP 7700SFF. Managed to reach the Desktop screen, although it took a couple minutes to get there. I can't remember if it's normal to take this much time when booting from CD. No reboot loop, though. The video was corrupted in the end, but this should be another ticket, I guess.

comment:15 Changed 5 years ago by jackburton

Sorry, closed too fast. Still the same problem, vidrep ?

comment:16 Changed 5 years ago by jackburton

BIOS settings for Hard drives were set to "IDE", not "RAID".

comment:17 Changed 5 years ago by vidrep

I took that PC to the electronics recyclers last week. I still find it odd that every OS except Haiku would boot.

comment:18 Changed 13 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.