Opened 6 years ago

Closed 5 years ago

#10622 closed bug (fixed)

Web+ crashing on Blogger posts list

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev46955.

This crash is reproducible when running Web+ with LD_PRELOAD=/system/lib/x86/libroot_debug.so by logging into a Blogger account and going to the "post list".

Without libroot_debug.so, it's not reproducible, but I initially also got a crash, which led me try with libroot_debug.so. I'll attach both reports.

Attachments (2)

WebPositive-11822-debug-02-03-2014-08-37-04.report (43.4 KB ) - added by humdinger 6 years ago.
running web+ with libroot_debug.so
WebPositive-788-debug-02-03-2014-08-24-30.report (130.0 KB ) - added by humdinger 6 years ago.
running web+ normally

Download all attachments as: .zip

Change History (4)

by humdinger, 6 years ago

running web+ with libroot_debug.so

by humdinger, 6 years ago

running web+ normally

comment:1 by pulkomandy, 6 years ago

The libroot_debug.so one is fixed by https://github.com/haiku/webkit/commit/145213351303ad001425e3c2c4c547f7b30354e7 .

The initial crash may be related, can you reproduce it? (you will ave to wait for a new WebKit package for this...)

comment:2 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

Assuming the original crash had the same root cause, closing this. Please reopen if you can still get it to crash.

Note: See TracTickets for help on using tickets.