Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10621 closed bug (fixed)

Web+ can't scroll with keyboard anymore

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #10665
Has a Patch: no Platform: All

Description (last modified by humdinger)

This is hrev46955.

With the newest web+, you can't scroll a website via space, cursor up/down, page up/down.

Pressing a key hides the mouse pointer, even if that is disabled in the settings. Just like web+ would think that I'm inside a testfield, which where hiding the mouse cursor is normal.

Change History (7)

comment:1 Changed 5 years ago by humdinger

Description: modified (diff)

comment:2 Changed 5 years ago by jscipione

Works for me. Make sure you're not focused on the URL bar.

comment:3 Changed 5 years ago by pulkomandy

It only works sometimes. If you focus a text field inside a page, then leave it by clicking elseswhere, scrolling stops working. And there seem to be some other cases.

comment:4 Changed 5 years ago by humdinger

Seriously, John...? Of course I'm not in the URL bar. :)

It does work after e.g. opening a site from a bookmark, as long as you don't click anywhere into the page. After you do, it won't and acts as if you're in a textfield (hides cursor, no page-scrolling).

comment:5 Changed 5 years ago by pulkomandy

Fixed in https://github.com/haiku/webkit/commit/1b790a3abdbba1e96cc1cc5fe95d5d9b5ef643a9. I'll try to do another release of haikuwebkit soon, but there are some other important bugs I'd like to catch first.

comment:6 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: newclosed

comment:7 Changed 5 years ago by anevilyak

Blocking: 10665 added

(In #10665) Duplicate of #10621.

Note: See TracTickets for help on using tickets.