Opened 5 years ago

Closed 5 years ago

Last modified 13 months ago

#10627 closed bug (no change required)

Display tears and KDL

Reported by: vidrep Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev46955_gcc2_hybrid Write anyboot image to USB drive from a4.1 Reboot system Icons light Display tears horizontally (see attached photo) KDL (see attached photo) This is an intermittent problem, happening on 2 of 6 boot attempts.

Attachments (4)

IMG_0116.JPG (1.3 MB) - added by vidrep 5 years ago.
IMG_0117.JPG (1.9 MB) - added by vidrep 5 years ago.
listdev (2.5 KB) - added by vidrep 5 years ago.
syslog (237.6 KB) - added by vidrep 5 years ago.

Change History (16)

Changed 5 years ago by vidrep

Attachment: IMG_0116.JPG added

Changed 5 years ago by vidrep

Attachment: IMG_0117.JPG added

Changed 5 years ago by vidrep

Attachment: listdev added

Changed 5 years ago by vidrep

Attachment: syslog added

comment:1 Changed 5 years ago by anevilyak

With all due respect, it really isn't helping anything for you to keep posting more and more of these KDL tickets. They're pretty much without exception always the same exact USB problems you seem to have, of which there are already tons of duplicates, and it simply clutters the bugtracker and makes it more difficult for anyone that winds up looking into them to keep track.

comment:2 Changed 5 years ago by vidrep

When latest build has video tearing, the previous has a white screen, and the previous a black screen, how am I supposed to know if they are related to a USB problem and not different video problems, or that more than one bug is involved?

comment:3 Changed 5 years ago by anevilyak

The panic message in every single case is related to reading from a disk device.

comment:4 Changed 5 years ago by umccullough

Because the KDL shows that it's timing out when accessing your disk... which is unrelated to video.

My guess is that the timeout while trying to access the disk is causing all sorts of latency issues on your machine, which might affect video performance as well - and if USB shares an interrupt with the video hardware, perhaps it's even causing hardware conflicts.

comment:5 Changed 5 years ago by umccullough

Another suggestion might be to install Haiku directly to the hard drive on the machine and test that way - it may solve a lot of your problems.

comment:6 Changed 5 years ago by vidrep

These issues are occurring while trying to boot from the installation media, so I can install to a hard drive partition. Currently I have an alpha 4.1, dev, and x86_64 partition created on each HDD, on 3 different PC's. I am not running Haiku Live from the USB drive as you suppose. I could try both USB and CD to see if it makes any difference.

Last edited 5 years ago by vidrep (previous) (diff)

comment:7 Changed 5 years ago by vidrep

I tried installing from a new USB drive and CD tonight. The CD iso boots to the installation screen and installs normally without issues. The anyboot image on the USB drive KDL's as described in the ticket. Shall I ignore any further USB related KDL's from now on?

comment:8 Changed 5 years ago by luroh

Blocking: 7665 added

comment:9 Changed 5 years ago by diver

Component: - GeneralDrivers/USB
Owner: changed from nobody to mmlr

comment:10 Changed 5 years ago by vidrep

I no longer have the PC which was triggering this issue. The ticket can probably be closed.

comment:11 Changed 5 years ago by pulkomandy

Resolution: no change required
Status: newclosed

Ok, thanks for the update. If anyone else can reproduce this, please reopen the ticket.

comment:12 Changed 13 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.