Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#10626 closed bug (fixed)

WebPositive renders slashdot article header transparent

Reported by: cb88 Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

http://slashdot.org You can highlight the article headers and the show up otherwise they are trasparent/white.

Attachments (2)

screenshot5.png (240.1 KB ) - added by cb88 6 years ago.
Qupzilla rendering (correct)
screenshot6.png (185.8 KB ) - added by cb88 6 years ago.
WebPositive rendering (incorrect - article header missing with selected text also)

Download all attachments as: .zip

Change History (8)

by cb88, 6 years ago

Attachment: screenshot5.png added

Qupzilla rendering (correct)

comment:1 by anevilyak, 6 years ago

Sounds like a duplicate of #10623.

by cb88, 6 years ago

Attachment: screenshot6.png added

WebPositive rendering (incorrect - article header missing with selected text also)

comment:2 by cb88, 6 years ago

Agreed, possibly also related to https://dev.haiku-os.org/ticket/10624

comment:3 by pulkomandy, 6 years ago

Not a duplicate of these two other tickets. The background for these titles should be a gradient:

background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#3c8dbe), to(#3c7c9d));

We don't draw this properly yet, it needs some improvements to our gradient code, I guess. The syntax is here: https://www.webkit.org/blog/175/introducing-css-gradients/ So this looks like a simple vertical gradient. I'll see if I can fix our gradient code to display it.

comment:5 by pulkomandy, 6 years ago

Resolution: fixed
Status: newclosed

comment:6 by markh, 5 years ago

I'm not sure if I should create a new ticket for this, but it still seems to happen, but not for the first article. The first article renders correctly, but the second article has the same problem as mentioned in this ticket.

Running WebPositive version: HaikuWebKit 1.3.1 WebKit 538.33

This is on Haiku with reversion href47313-dirty [master].

Note: See TracTickets for help on using tickets.