Opened 5 years ago

Closed 5 years ago

#10674 closed bug (fixed)

Captcha system seems to be not working normally

Reported by: codewrangler Owned by: zooey
Priority: normal Milestone:
Component: Website/Trac Version:
Keywords: Captcha Cc:
Blocked By: Blocking: #10705
Has a Patch: no Platform: All

Description

When updating or creating a Ticket, I get the error page without first being presented with a way to input or see a Captcha (see attachment). The error screen has no 'submit' button, but hitting the enter/return key causes the form to be submitted.

Attachments (1)

Screen Shot 2014-03-12 at 10.20.33 AM.png (106.4 KB) - added by codewrangler 5 years ago.
Captcha error

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by codewrangler

Captcha error

comment:1 Changed 5 years ago by luroh

Blocking: 10705 added

comment:2 Changed 5 years ago by luroh

Owner: changed from haiku-web to zooey
Status: newassigned

Since the captcha actually didn't seem to stop our recent spammer, maybe it should be removed.

comment:3 Changed 5 years ago by zooey

I'm not sure, but I believe the described behaviour may just be how it is supposed to work:

AFAICS, the spamfilter plugin uses a couple of tests (both internal and external like mollom) to determine the quality of a ticket/comment. If that quality is above a configured level (currently 10 points), Trac will accept it, without showing the captcha.

Our current problem seems to be that the quality never reaches 10, so the captcha is shown for every submission. The cause of this seems to be that only the mollom and the bayes filter plugin actually increase the quality level, when they consider the contribution to be ok. I have no idea why the other configured plugins (e.g. akismet) never contribute to the quality level.

I have lowered the value for the minimum quality to 5 now, let's see how that works out.

BTW: the spammer we had recently didn't like the captcha very much and actually failed to solve it several times and gave up (only to come back at a later time). So I believe that the captcha did help getting rid of that spammer.

comment:4 Changed 5 years ago by zooey

Resolution: fixed
Status: assignedclosed

I think the spam-filter is working quite good now, the captcha is shown only rarely.

Note: See TracTickets for help on using tickets.