Opened 6 years ago

Last modified 2 years ago

#10695 assigned bug

Tracker copying large files to FAT32 USB stick slows and then fails, but cp succeeds (merely slows)

Reported by: Kev Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I've had this happen just now on an 8 GB Silicon Power USB stick under both Alpha 4.1 and hrev47020. I go to copy multiple files to the stick from a BeFS volume via drag and drop. The first file appears and some MB (210, then 75, then 150 in my three attempts on hrev47020) copy at about 20 MiB/s, and then suddenly the copying stops, and only goes in 3-MB spurts after that. For larger files (~1 GB), eventually (after 300-700 MB, AFAICT after reboot that's what's there) I come back to the computer and the screen has gone blank, and the keyboard will not light up with num lock presses, and the screen will not turn on from doing any keypresses or mouse clicks/movement, until I reboot the computer.

I tried the same thing with cp, and under Haiku Alpha 4.1 it gave me a kernel panic. After that, hrev47020 wouldn't even browse the folder of the USB stick without a kernel panic, so I used an XP computer's check disk to repair the stick. After that, I tried 'cp .../*' on hrev47020 (with a Tracker folder open so I could watch the files as they copied) and while the slowing behaviour did happen still, when I came back later the files had copied successfully and the computer was fine and I could unmount the stick and carry on.

Change History (2)

comment:1 by diver, 6 years ago

Might be related to #5777.

comment:2 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned
Note: See TracTickets for help on using tickets.