Opened 5 years ago

Closed 3 months ago

#10696 closed bug (not reproducible)

Pe does not launch

Reported by: Kev Owned by: nobody
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This worked OK on hrev46992, but on hrev47020, launching Pe from the Deskbar menu or from Terminal does not work (nothing appears to happen.) In Terminal it says:

~> /boot/system/apps/Pe/Pe ~>

This was similar to behaviour I was having opening a file with StyledEdit, but this is just trying to open Pe without a file.

Attached is a debug report when I killed the team, which was not using any CPU. A subsequent launch attempt worked fine.

Attachments (1)

Pe-4394-debug-18-03-2014-20-45-43.report (8.6 KB) - added by Kev 5 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 years ago by Kev

Also, apologies if this is a duplicate, but Trac will not let me search for 'Pe' as a term.

Changed 5 years ago by Kev

comment:2 Changed 5 years ago by michel

I have seen this a few times. A reboot clears the problem.

comment:3 Changed 5 years ago by Kev

Thanks, that might provide a clue. Hopefully that's not the last word, though--I've had it happening more frequently lately, and "the Windows solution" leaves a bit of a bad taste (despite Haiku's fast rebooting time) ;-)

comment:4 Changed 5 years ago by michel

Of course. Just affirming that it's not just you.

comment:5 Changed 5 years ago by Kev

Ah, many thanks, michel. :)

comment:6 Changed 5 years ago by jessicah

The debug report unfortunately doesn't show anything useful. In such a case, you might need to enter KDL in order to get a backtrace for the currently executing Pe thread. I can't reproduce the same thing here, and I couldn't see anything in that revision range that would be remotely related to this issue.

comment:7 Changed 4 years ago by un_spacyar

I tested it in hrev48136 (x86_gcc2) and Pe works OK (both from Terminal, or from Deskbar menu). Maybe can be closed?

comment:8 Changed 3 months ago by waddlesplash

Resolution: not reproducible
Status: newclosed
Note: See TracTickets for help on using tickets.