Opened 6 years ago

Closed 5 years ago

#10759 closed bug (fixed)

Web+ rendering glitches on dev.haiku-os.org

Reported by: Kev Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by pulkomandy)

I'm not sure exactly what minimal case sets this off, but it was certainly reproducible in context (which is https://dev.haiku-os.org/ticket/10736 -- if you click 'reply' at my comment and try it there, you can get the same behaviour.)

  1. start at the above link (screenshot 1)
  2. try to single-backspace the end of the echo line
  3. the whole line (plus a sliver of the next line) disappears (2)
  4. 2-3 seconds later (when the preview is done updating) it reappears (3)
  5. type a " character, the line disappears again (looks like 2 again)
  6. 2-3 seconds later, the line reappears again (looks like 1 again)

hrev47114.

Attachments (3)

screenshot1.png (106.2 KB ) - added by Kev 6 years ago.
screenshot2.png (104.4 KB ) - added by Kev 6 years ago.
screenshot3.png (106.4 KB ) - added by Kev 6 years ago.

Download all attachments as: .zip

Change History (4)

by Kev, 6 years ago

Attachment: screenshot1.png added

by Kev, 6 years ago

Attachment: screenshot2.png added

by Kev, 6 years ago

Attachment: screenshot3.png added

comment:1 by pulkomandy, 5 years ago

Description: modified (diff)
Resolution: fixed
Status: newclosed

Does not happen anymore in HaikuWebkit 1.4.

Note: See TracTickets for help on using tickets.