Opened 5 years ago

Closed 5 years ago

#10788 closed bug (invalid)

Bootstrap build fails for arm with "ImportError: No module named __version__"

Reported by: kallisti5 Owned by: zooey
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The error comes from Haikuporter, the cause may be environmental (python 3.4.0)

Haikuporter: a7a38f1 (I tried going all the way back to 7dbd2b1 and still saw the same issue)

../configure -j4 --build-cross-tools arm ../../buildtools/ --bootstrap ../../haikuporter/haikuporter ../../haikuports.cross/ ../../haikuports --target-board beagle

jam -q @bootstrap-raw

End result (hrev47169)

AddVariableToScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_arm.hpkg/scripts/haiku.package-init-vars 
InitScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_arm.hpkg/scripts/haiku.package-make-dirs 
CreateContainerMakeDirectoriesScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_arm.hpkg/scripts/haiku.package-make-dirs 
InitScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_arm.hpkg/scripts/haiku.package-copy-files 
AppendToContainerCopyFilesScriptSingleFile <hpkg_-haiku_cross_devel_sysroot_arm.hpkg>haiku.package-copy-files-dummy-develop/lib-kernel.so 
InitScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg/scripts/haiku.package-init-vars 
AddTargetVariableToScript1 <unique!target>_target_96 
AddTargetVariableToScript1 <unique!target>_target_07 
AddTargetVariableToScript1 <unique!target>_target_17 
AddTargetVariableToScript1 <unique!target>_target_27 
AddTargetVariableToScript1 <unique!target>_target_37 
AddTargetVariableToScript1 <unique!target>_target_47 
AddTargetVariableToScript1 <unique!target>_target_57 
AddTargetVariableToScript1 <unique!target>_target_67 
AddTargetVariableToScript1 <unique!target>_target_77 
AddVariableToScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg/scripts/haiku.package-init-vars 
InitScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg/scripts/haiku.package-make-dirs 
CreateContainerMakeDirectoriesScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg/scripts/haiku.package-make-dirs 
InitScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg/scripts/haiku.package-copy-files 
AppendToContainerCopyFilesScriptSingleFile <hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg>haiku.package-copy-files-dummy-develop/lib-kernel.so 
AppendToContainerCopyFilesScript <hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg>haiku.package-copy-files-dummy-develop/lib 
AddDirectoryToContainerCopyFilesScript <hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg>develop/headers/config/-/<copy-directory-to-container>/home/kallisti5/Code/haiku/headers/config 
AddDirectoryToContainerCopyFilesScript <hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg>develop/headers/glibc/-/<copy-directory-to-container>/home/kallisti5/Code/haiku/headers/glibc 
AddDirectoryToContainerCopyFilesScript <hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg>develop/headers/os/-/<copy-directory-to-container>/home/kallisti5/Code/haiku/headers/os 
AddDirectoryToContainerCopyFilesScript <hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg>develop/headers/posix/-/<copy-directory-to-container>/home/kallisti5/Code/haiku/headers/posix 
AddDirectoryToContainerCopyFilesScript <hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg>develop/headers/bsd/-/<copy-directory-to-container>/home/kallisti5/Code/haiku/headers/compatibility/bsd 
AddDirectoryToContainerCopyFilesScript <hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg>develop/headers/gnu/-/<copy-directory-to-container>/home/kallisti5/Code/haiku/headers/compatibility/gnu 
InitScript1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages_build/hpkg_-haiku_cross_devel_sysroot_stage1_arm.hpkg/scripts/haiku.package-extract-files 
BuildHaikuPackage1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages/haiku_cross_devel_sysroot_stage1_arm.hpkg 
haiku_cross_devel_sysroot_stage1_arm.hpkg: Removing and re-creating package contents dir ...
haiku_cross_devel_sysroot_stage1_arm.hpkg: Collecting package contents ...
haiku_cross_devel_sysroot_stage1_arm.hpkg: mimeset'ing package contents ...
haiku_cross_devel_sysroot_stage1_arm.hpkg: Creating the package ...
BootstrapRepositoryFetchPackage1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/repositories/HaikuPortsCross-build/packages/haikuporter-0-1-any.hpkg 
Traceback (most recent call last):
  File "/home/kallisti5/Code/haiku/generated.arm/../../haikuporter/haikuporter", line 9, in <module>
    from HaikuPorter.Main import Main
  File "/home/kallisti5/Code/haikuporter/HaikuPorter/__init__.py", line 6, in <module>
    from __version__ import *
ImportError: No module named '__version__'


package="/home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/repositories/HaikuPortsCross-build/packages/haikuporter-0-1-any.hpkg"
if [ -e "$package" ]; then
exit 0
fi


haikuCrossDevelPackage="/home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/packages/haiku_cross_devel_sysroot_stage1_arm.hpkg"
if [ "x$haikuCrossDevelPackage" = "x${haikuCrossDevelPackage#/}" ]; then
haikuCrossDevelPackage="`pwd`/$haikuCrossDevelPackage"
fi


secondaryCrossDevelPackages=
if [ -n  ]; then
for secondaryCrossDevelPackage in  ; do
if [ "x$secondaryCrossDevelPackage" = "x${secondaryCrossDevelPackage#/}" ]; then
secondaryCrossDevelPackage="`pwd`/$secondaryCrossDevelPackage"
fi
if [ -n "$secondaryCrossDevelPackages" ]; then
secondaryCrossDevelPackages="secondaryCrossDevelPackages,$secondaryCrossDevelPackage"
else
secondaryCrossDevelPackages="--secondary-cross-devel-package=$secondaryCrossDevelPackage"
fi
done
fi
portName=`basename "$package" | sed 's@-.*@@'`
case $portName in
*_devel|*_doc|*_source|*_debuginfo)
portName=`echo $portName | sed 's@_[^_]*$@@'`
;;
*_source_rigged)
portName=`echo $portName | sed 's@_source_rigged$@@'`
;;
esac

cd /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/repositories/HaikuPortsCross-build

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/kallisti5/Code/haiku/generated.arm/objects/linux/lib
if [ -n "$secondaryCrossDevelPackages" ]; then
/home/kallisti5/Code/haiku/generated.arm/../../haikuporter/haikuporter  \
--cross-devel-package "$haikuCrossDevelPackage" \
"$secondaryCrossDevelPackages" $portName
else
/home/kallisti5/Code/haiku/generated.arm/../../haikuporter/haikuporter  \
--cross-devel-package "$haikuCrossDevelPackage" $portName
fi

...failed BootstrapRepositoryFetchPackage1 /home/kallisti5/Code/haiku/generated.arm/objects/haiku/arm/packaging/repositories/HaikuPortsCross-build/packages/haikuporter-0-1-any.hpkg ...

BUILD FAILURE:
...failed updating 1 target(s)...
...skipped 38 target(s)...
...updated 52 target(s)...

Change History (2)

comment:1 Changed 5 years ago by kallisti5

Owner: changed from bonefish to zooey
Status: newassigned

comment:2 Changed 5 years ago by kallisti5

Resolution: invalid
Status: assignedclosed

This was due to Python3. The haikuports scripts only work with Python2 atm.

Note: See TracTickets for help on using tickets.