Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#108 closed bug (fixed)

BMenus crashing

Reported by: genki@… Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hi,

Recent changes to BMenu and friends made apps crash while messing around with the menus.

Change History (7)

comment:1 by genki@…, 14 years ago

It happens both under qemu and real hardware although it seems to be easier to reproduce under qemu.

Here is how:

  1. Single-click on a menu, for example "Settings" in the Terminal app.
  2. Move mouse cursor to center of app. Menu disappeares. (should this really

happen?)

  1. Move mouse cursor back to "Settings" label and click as fast as possible.
  2. Crash.

stackdump: Thread 178 called debugger(): Looper must be locked. Reading symbols from /boot/beos/system/lib/libroot.so...done. <blabla> Loaded symbols for /boot/beos/system/lib/libmedia.so [Switching to team /boot/beos/apps/Terminal (96) thread menu_tracking (178)] 0x0024d7e7 in _kern_debugger () from /boot/beos/system/lib/libroot.so (gdb) bt #0 0x0024d7e7 in _kern_debugger () from /boot/beos/system/lib/libroot.so #1 0x00248c0f in debugger () from /boot/beos/system/lib/libroot.so #2 0x0037233e in BLooper::check_lock () from /boot/beos/system/lib/libbe.so #3 0x003f479e in BView::check_lock_no_pick ()

from /boot/beos/system/lib/libbe.so

#4 0x003f234c in BView::CountChildren () from /boot/beos/system/lib/libbe.so #5 0x003f5d49 in BWindow::CountChildren () from /boot/beos/system/lib/libbe.so #6 0x003c4b41 in BMenuWindow::SetMenu () from /boot/beos/system/lib/libbe.so #7 0x003bd8e8 in BMenu::_show () from /boot/beos/system/lib/libbe.so #8 0x003bf2e9 in BMenu::SelectItem () from /boot/beos/system/lib/libbe.so #9 0x003c08f3 in BMenuBar::Track () from /boot/beos/system/lib/libbe.so #10 0x003c079a in BMenuBar::TrackTask () from /boot/beos/system/lib/libbe.so #11 0x0024cdb0 in thread_entry () from /boot/beos/system/lib/libroot.so #12 0x70247fec in ?? () (gdb)

comment:2 by jackburton, 14 years ago

Seems to be caused by your latest work on BMenus, Axel. Have you still got pending changes there, or can I try to fix the problem ?

comment:3 by axeld, 14 years ago

Feel free to fix it, Stefano! I don't think that my changes actually caused it, I guess they just make it more likely to happen (I remember having seen this before).

comment:4 by axeld, 14 years ago

Owner: changed from axeld to jackburton

comment:5 by jackburton, 14 years ago

Status: newclosed

comment:6 by jackburton, 14 years ago

Should be fixed in rev. 16223

comment:7 by jackburton, 14 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.