Opened 13 years ago

Closed 12 years ago

#109 closed bug (fixed)

Resize/Restore button draws over mouse

Reported by: j_freeman@… Owned by: stippi
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by stippi)

The Resize/Restore Window button in applications will draw over the mouse cursor when clicked.

I was running Philipp Schmid's rev16108 (2006-02-02) HDD image under VMware Player to produce this quirk. To reproduce this bug, simply move the mouse cursor over any Resize/Restore Window button on an application's titlebar, click, and look closely. You should see the yellow lines (of the button) over the cursor (unless, of course, the cursor was moved).

Change History (15)

comment:1 Changed 13 years ago by j_freeman@…

This happens on the Close Window button as well. Just put the cursor over the Close button and press down (but do not release) and you will see the border of the button drawn over the mouse cursor.

comment:2 Changed 13 years ago by axeld

This is a known bug, but thanks for reporting.

comment:3 Changed 13 years ago by axeld

Status: newassigned

comment:4 Changed 13 years ago by j_freeman@…

I don't know if it's the same bug as this one, but the same effect happens with checkboxes, while unchecking a checked one. Checking an empty checkbox appears to be immune to this bug.

comment:5 Changed 13 years ago by axeld

Owner: changed from axeld to stippi
Status: assignednew

comment:6 Changed 13 years ago by axeld

This is rather odd, as the region that draws over the mouse shouldn't be updated at all, AFAICT. I'm letting Stephan try to solve this, as he has a better understanding of the drawing engine.

comment:7 Changed 13 years ago by diver

Cc: diver added

comment:8 Changed 13 years ago by mmlr

Cc: korli@… added

comment:9 Changed 13 years ago by mmlr

* Bug 554 has been marked as a duplicate of this bug. *

comment:10 Changed 13 years ago by mmlr

To add just a bit more oddness to this bug, this doesn't happen on real hardware for me. I can only reproduce it under QEMU.

comment:11 Changed 13 years ago by j_freeman@…

(In reply to comment #6)

To add just a bit more oddness to this bug, this doesn't happen on real hardware for me. I can only reproduce it under QEMU.

Same here, only happens under VMware or Qemu... not real hardware. Bizarre.

comment:12 Changed 13 years ago by stippi

Maybe not so bizarre. It should probably happen on real hardware too if you chose a 16 bit screen depth.

comment:13 Changed 13 years ago by j_freeman@…

(In reply to comment #8)

Maybe not so bizarre. It should probably happen on real hardware too if you

chose a 16 bit screen depth.

I've tested this in 32-bit colorspace in VMware, also. You'd think if it did this there, it'd do it on real hardware in 32-bit colorspace too.

Another note, yesterday I was testing on real hardware... and it looked like the yellow lines were being drawn, but the mouse cursor would draw over it... There'd definitely be a short delay and you could see the yellow lines being drawn if you look close enough. Does the cursor behave differently on real hardware, i.e. hardware cursor?

I also thought of another thing, I haven't tested this on real hardware using VESA... only using the Rudolf's GF driver. So could this only effect VESA modes? That would explain why I've only reproduced it in VMware.

comment:14 Changed 12 years ago by stippi

Description: modified (diff)
Platform: All
Status: newassigned

comment:15 Changed 12 years ago by stippi

Resolution: fixed
Status: assignedclosed

Fixed in 18842.

Note: See TracTickets for help on using tickets.