Opened 5 years ago

Last modified 8 months ago

#10873 new bug

Booting problems on Chromebook 720 - USB related

Reported by: cian Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB/EHCI Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm attempting to boot Haiku on an Acer Chromebook 720 (http://www.acer.ie/ac/en/GB/content/series/c720) - this is an x86 machine with a BIOS emulator (SeaBIOS - http://www.seabios.org/SeaBIOS) which has been shown to run a number of other x86 operating systems.

The bootloader loads succesfully, albeit only if you allow SeaBIOS to select a boot device automatically - if you select one yourself it will crash. All icons light but the desktop does not appear

Looking at the onscreen debug information, it loops with these two lines appearing:

"usb error control pipe 9: timeout waiting for queued request to complete" "usb error hub 8: error updating port status"

I have replaced the USB key in use and have tried a new download of the anyboot image to see if this was connected in any way but it appears not.

I've found reference to changes being required to USB support in DragonflyBSD and FreeBSD so there may be an issue with the controller.

Most recently tried with hrev47259

Change History (7)

comment:1 by luroh, 5 years ago

The C720 seems to have a USB 2.0 and a 3.0 port, have you tried them both?

comment:2 by luroh, 5 years ago

Blocking: 7665 added

comment:3 by cian, 5 years ago

I'd been using the USB3 port previously. Just tried now - on the USB2 port the same looping occurs, but it terminates with "usb error hub 8: usb_disk: operation 0x35 failed at the SCSI level" "error updating port status" eventually.

comment:5 by waddlesplash, 14 months ago

Keywords: boot-failure added

comment:6 by waddlesplash, 14 months ago

Blocking: 7665 removed

comment:7 by waddlesplash, 8 months ago

Component: Drivers/USBDrivers/USB/EHCI
Note: See TracTickets for help on using tickets.