Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10905 closed bug (fixed)

Possible typo in posix/search.h

Reported by: diger Owned by: korli
Priority: normal Milestone: R1/beta1
Component: System/POSIX Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

http://cgit.haiku-os.org/haiku/tree/headers/posix/search.h#n18

typedef struct entry {
	char *keyr;
	void *data;
} ENTRY;

http://pubs.opengroup.org/onlinepubs/007904875/basedefs/search.h.html

The <search.h> header shall define the ENTRY type for structure entry which shall include the following members:

char    *key
void    *data

What is the purpose of this difference???

Change History (5)

comment:1 by pulkomandy, 5 years ago

Owner: changed from nobody to korli
Status: newassigned

Looks like a typo indeed. Assigning ticket to korli as he introduced the file.

comment:2 by korli, 5 years ago

Resolution: fixed
Status: assignedclosed

Not a typo, written as specified by the spec. ENTRY is a type in the global name space, entry is a type in the struct name space. Does it answer your question?

comment:3 by pulkomandy, 5 years ago

I think the problem is "key" vs "keyr" ?

comment:4 by korli, 5 years ago

Couldn't see the typo, thanks Adrien. Fixed in hrev47330.

comment:5 by pulkomandy, 5 years ago

Milestone: R1/alpha5R1/beta1
Note: See TracTickets for help on using tickets.