Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10996 closed enhancement (duplicate)

Add missing features to CddaFS and deprecate CDPlayer in favor of it

Reported by: waddlesplash Owned by: bga
Priority: normal Milestone: R1
Component: File Systems/cdda Version: R1/Development
Keywords: Cc:
Blocked By: #9065 Blocking:
Has a Patch: no Platform: All

Description

This is hrev47449.

  1. Insert audio CD into drive
  2. Open CDPlayer
  3. CDPlayer claims it is playing but no sound comes out
  4. Open the "Audio CD" from the Desktop and open one of the tracks in MediaPlayer
  5. Sound comes out

I vote to wipe CDPlayer off the face of the earth and give the CD-as-WAV filesystem support to lookup CDDB, which is the only thing CDPlayer can do that it can't do right now.

Change History (10)

comment:1 by tqh, 5 years ago

You need to connect the cdplayer hardware to the soundcard and raise the volume for that input. It's a different audio path. For connecting headphones to the player and such.

comment:2 by vidrep, 5 years ago

This is a duplicate of ticket #9065. SATA cd/dvd audio is not supported in Haiku.

comment:3 by waddlesplash, 5 years ago

vidrep: No, MediaPlayer can play the files just fine. tqh: That should happen automatically without having to open Cortex.

comment:4 by vidrep, 5 years ago

Waddlesplash: Yes I know MediaPlayer works, but the CDPlayer app does not work with SATA drives. However, an IDE drive with a audio cable will work. I agree CD player should be retired and have the functions merged into MediaPlayer.

Last edited 5 years ago by vidrep (previous) (diff)

comment:5 by waddlesplash, 5 years ago

Component: Applications/CDPlayerFile Systems/cdda
Owner: changed from darkwyrm to bga
Summary: CDPlayer does not workAdd missing features to CddaFS and deprecate CDPlayer in favor of it
Type: bugenhancement

Ah, OK. Since someone else agrees with me, I'll make that the topic of this bug report.

comment:6 by pulkomandy, 5 years ago

Blocked By: 9065 added
Resolution: duplicate
Status: newclosed

It is a duplicate indeed.

The option of direct replay in CDPlayer style is nice to have on computers that support it, because it uses absolutely 0 CPU (the audio is forwarded from the CD drive directly to the sound card using a special cable). The feature is sadly gone from newer computers, making CDPlayer useless in that case. I'm not sure it's possible to reliably detect if the needed cable is plugged.

comment:7 by bonefish, 5 years ago

Not that I still use CDs these days, but in the olden days the advantage of CDPlayer over a CDDA based player was that the former would cause the drive to run at constant -- more or less silent -- 1x speed while the latter would cause -- very noisy! -- high speed bursts.

comment:8 by tqh, 5 years ago

Waddlesplash, the sound doesn't really involve the computer. It is the internal hardware and amplifier in the cd. You wouldn't even need a soundcard to listen to cds. So try to understand that cdplayer does not play sound. It only controls play / pause / skip on the CD. Kind of like a remote.

comment:9 by waddlesplash, 5 years ago

bonefish: Actually, I think many people now just rip the CDs to their HDDs, and in that sense, CDDAFS is pretty good.

tqh: I understand. :) I'm saying that since most people no longer are on PCs that have this hardware, we should remove it from Deskbar so people aren't confused. If anyone wants it, they can start it from the command line or create a symlink themselves.

comment:10 by tqh, 5 years ago

That I can agree with.

Note: See TracTickets for help on using tickets.