Opened 7 years ago

Closed 5 years ago

#9065 closed bug (invalid)

Audio CD does not play

Reported by: dsjonny Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #10996
Has a Patch: no Platform: All

Description

I cannot play audio CD with CDPlayer apllication. The program shows the tracks, get the track info (from the name of the song and the artist), but if I start to play, than it only switch to the next track, and the next track, until if finished the disk, but does not play anything.

I have checked it with cdrecord -media-info, and the tracks are there, and shows it as audio CD, and Haiku mounts it automatically, and the tracks are there too (with song name).

I have tried it on a laptop and on a desktop PC too with 2 different (internal) DVD-writer.

And I also tried it with written disk, and with original disks too.

Attachments (1)

syslog 2.zip (45.0 KB) - added by dsjonny 7 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 7 years ago by luroh

Milestone: R1/alpha4R1

Are you really experiencing this problem using R1/alpha3? If so, could you please check if the problem is still present in a nightly build?

comment:2 Changed 7 years ago by dsjonny

Version: R1/alpha3R1/Development

I always use the latest nightly image, but there is no alpha4 in the list. If the development is the alpha4 then I will use that in the future.

comment:3 Changed 7 years ago by luroh

Please always state what revision and GCC flavour you are running, "the latest" does not suffice (a few days later, such a statement may not mean a whole lot). There is more information available about filing proper bug reports at wiki:ReportingBugs Yes, R1/Development is the version you should select if you're running nightlies.

comment:4 Changed 7 years ago by dsjonny

So, I tried it with the hrevr1alpha4-44631 and many previous version.

comment:5 Changed 7 years ago by diver

Please attach your syslog.

Changed 7 years ago by dsjonny

Attachment: syslog 2.zip added

comment:6 Changed 7 years ago by dsjonny

I have attached the zipped logfile.

comment:7 Changed 7 years ago by dsjonny

Component: Applications/CDPlayerDrivers/Disk
Owner: changed from darkwyrm to marcusoverhagen

Found something: I have tried Haiku (alpha 4.1) on my old PC, and there was no problem. The only difference is: in my old PC the DVD is connected to the IDE channel. So, the problem is only with the SATA optical devices.

comment:8 Changed 6 years ago by dsjonny

Using 45432 nightly it is still available.

comment:9 Changed 5 years ago by vidrep

I can confirm the same problem exists on latest builds. Drive is detected and mounted, but no audio output on SATA drives using CD player application. Display shows tracks and time as if it were playing. If you click on individual tracks media player is launched and plays audio without issues.

comment:10 Changed 5 years ago by pulkomandy

Blocking: 10996 added

(In #10996) It is a duplicate indeed.

The option of direct replay in CDPlayer style is nice to have on computers that support it, because it uses absolutely 0 CPU (the audio is forwarded from the CD drive directly to the sound card using a special cable). The feature is sadly gone from newer computers, making CDPlayer useless in that case. I'm not sure it's possible to reliably detect if the needed cable is plugged.

comment:11 Changed 5 years ago by waddlesplash

I vote to leave CDPlayer in the images but remove it from the Deskbar menu, so as not to confuse users but for those who know they have the right hardware to still be able to use it.

comment:12 Changed 5 years ago by bonefish

I'd rather put it in a separate package and don't include it in the default installation.

comment:13 Changed 5 years ago by waddlesplash

Makes sense. I should move it to HaikuArchives then?

comment:14 Changed 5 years ago by bonefish

Good question. To make it an optional package it doesn't necessarily have to be moved out of the repository, but it could be done, of course.

comment:15 Changed 5 years ago by waddlesplash

Component: Drivers/DiskApplications
Resolution: invalid
Status: newclosed

CDPlayer has been removed from the repo.

Note: See TracTickets for help on using tickets.